Opened 6 years ago

Closed 6 years ago

#9126 closed defect (duplicate)

microdesc_cache_rebuild(): Bug

Reported by: azoughbi Owned by: asn
Priority: Medium Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version: Obfsproxy: 0.1.4
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1461129, but I should be at 1461162

Child Tickets

Change History (6)

comment:1 Changed 6 years ago by rransom

Component: ObfsproxyTor

Yet another bloody duplicate of one of the microdescriptor bugs.

comment:2 Changed 6 years ago by nickm

Status: newneeds_information

What version of Tor? This looks just like #8822.

comment:3 Changed 6 years ago by Jason

I think my tor bundle has the same issue:

[Warning] Couldn't dump microdescriptor (wrote 4294967295 out of 333): Invalid argument
[Warning] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 5043, but I should be at 5076

OS: Windows XP

Tor version: tor-pluggable-transports-browser-2.4.12-alpha-2-pt1_en-US

comment:4 Changed 6 years ago by nickm

Milestone: TorBrowserBundle 2.3.x-stableTor: 0.2.5.x-final
Priority: criticalnormal

Okay, I'm *really* interested in knowing if this recurs in Tor 0.2.4.13-alpha or later. I know that 0.2.4.12-alpha had this bug -- the question is whether Tor 0.2.4.13-alpha fixed it.

comment:5 Changed 6 years ago by nickm

Keywords: tor-client added

comment:6 Changed 6 years ago by nickm

Resolution: duplicate
Status: needs_informationclosed

Closing as probably a duplciate of #8822. Please reopen if this happens with a recent version of Tor (like 0.2.4.13-alpha or later).

Note: See TracTickets for help on using tickets.