Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#9144 closed defect (fixed)

Untranslated strings are still removed/empty in Transifex output

Reported by: mikeperry Owned by: phoul
Priority: Very High Milestone:
Component: Community/Translations Version:
Severity: Keywords:
Cc: mttp, mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It appears that untranslated strings are still empty for Firefox DTD strings, and commented out for property strings. This is causing the partially localized bundles (like Farsi) to have rendering errors. Worse, empty properties cause exceptions in Torbutton and Tor Launcher, which will alter the browser behavior in unexpected ways, possibly including interfering with important privacy settings and even proxy configuration.

Is there any way to get Transifex to provide us with a copy of the DTD and property files that actually have the English placeholders active?

Child Tickets

Attachments (2)

MissingStrings.png (32.3 KB) - added by Sherief 6 years ago.
FixedStrings.png (21.7 KB) - added by Sherief 6 years ago.

Download all attachments as: .zip

Change History (32)

comment:1 Changed 6 years ago by Sherief

Problem still exists in Torbutton - about:tor homepage - Arabic version

I can see 2 untranslated (probably the empty strings I pointed before) and they do not appear in transifex's interface.

comment:2 Changed 6 years ago by runa

I will contact the Transifex developers and ask about this. If Transifex can not populate empty strings with the English strings, we have two options: (1) write a script to do it, (2) only use complete translations.

Also, is this blocking #8952 in any way? If not, I will start working on this ticket later today.

comment:3 Changed 6 years ago by runa

I've emailed the developers again, will update when I hear back.

comment:4 Changed 6 years ago by mikeperry

Keywords: MikePerry201307 added

If they don't say anything soon, I can try setting these to   and see what explodes.

comment:5 Changed 6 years ago by mikeperry

Ok, I pushed a new en-US aboutTor.dtd that uses   for these two strings... Let's see if we get another transifex exception in the mail for this update (when do they pull the resource file again? is it a 1/day cronjob?)

comment:6 in reply to:  5 Changed 6 years ago by Sherief

Replying to mikeperry:

Ok, I pushed a new en-US aboutTor.dtd that uses   for these two strings... Let's see if we get another transifex exception in the mail for this update (when do they pull the resource file again? is it a 1/day cronjob?)

approx 12 - 14 hours from now.

comment:7 Changed 6 years ago by mikeperry

Resolution: fixed
Status: newclosed

I assume this worked? Reopen if not.

Changed 6 years ago by Sherief

Attachment: MissingStrings.png added

comment:8 Changed 6 years ago by Sherief

Resolution: fixed
Status: closedreopened

Two Strings are still missing, please see the attached file.

comment:9 Changed 6 years ago by mikeperry

Keywords: MikePerry201308 added; MikePerry201307 removed
Parent ID: #8952

comment:10 Changed 6 years ago by mikeperry

Keywords: MikePerry201308 removed

comment:11 Changed 6 years ago by Sherief

Problem seems to be solved, today I logged into transifex and checked the Torbutton - about:tor homepage resource and I saw a couple of   so that means this is solved/fixed.

See attached: FixedStrings.png

Changed 6 years ago by Sherief

Attachment: FixedStrings.png added

comment:12 Changed 6 years ago by mikeperry

Actually the   thing seems to be a separate issue that got mixed in to this ticket.

The original issue is still there. I just checked out all the strings from #8952 and the partially completed strings are still emptied and commented out. This makes them unusable.

For two exmaples:
https://gitweb.torproject.org/translation.git/blob/refs/heads/abouttor-homepage:/ko/aboutTor.dtd
https://gitweb.torproject.org/translation.git/blob/refs/heads/torbutton-browserproperties:/ko/browser.properties

In the first file (aboutTor.dtd), the untranslated strings are all empty. This would mean that Korean users will get a completely blank about:tor page with nothing on it what-so-ever.

In the second file (browser.properties), the untranslated properties are commented out. This will cause exceptions in Torbutton and also Firefox, and will result in unexpected behavior or crashes.

comment:13 Changed 6 years ago by mikeperry

The behavior we need here is for the english placeholders to be present in partially translated locales, and not commented out or empty.

comment:14 Changed 6 years ago by runa

I have sent another email to Transifex support about this, will update when I hear something.

comment:15 Changed 6 years ago by mcs

Cc: mcs brade added

comment:16 Changed 6 years ago by mikeperry

Parent ID: #8952

comment:17 Changed 6 years ago by phoul

Cc: admin@… added

comment:18 Changed 6 years ago by phoul

Owner: changed from runa to phoul
Status: reopenedassigned

comment:19 Changed 6 years ago by phoul

Cc: admin@… removed

comment:20 Changed 6 years ago by phoul

I emailed OpenITP about this issue, and they have passed the concern along to Transifex. Will followup with OpenITP during our next call (sometime this month).

comment:21 Changed 6 years ago by phoul

During a meeting with OpenITP and Transifex today, a solution for the DTD issue was discussed / possibly found. Mike, could you please check https://gitweb.torproject.org/translation.git/blob/refs/heads/abouttor-homepage:/dz/aboutTor.dtd and let me know if this looks good to you?

comment:22 Changed 6 years ago by phoul

All DTD strings should now include the English placeholders. If I happened to miss a resource, please let me know.

comment:23 Changed 6 years ago by mikeperry

Ok, yes, this now seems true for DTD strings. We still need the same to happen for properties strings (placeholders are actually there, but commented out).

comment:24 Changed 6 years ago by phoul

This was discussed with Transifex, however they have asked if there is some sort of specification for Mozilla's ".properties" files.

Does anything like this exist?

comment:26 in reply to:  25 Changed 6 years ago by phoul

Replying to gk:

Yes: https://en.wikipedia.org/wiki/.properties

and

https://developer.mozilla.org/en-US/docs/XUL/Tutorial/Property_Files (section Properties)

Thanks gk, these have been sent along to Transifex.

Will update the ticket once I hear back.

comment:27 Changed 6 years ago by phoul

Please see https://gitweb.torproject.org/translation.git/blob/260c137c416568f7901c03e2e352b7d6a0dc9c88:/nn/brand.properties.

If this looks correct, then I will go ahead and apply the fix to the rest of the .properties branches and mark this ticket as resolved.

Last edited 6 years ago by phoul (previous) (diff)

comment:28 Changed 6 years ago by mikeperry

Yes, that file looks fine.

comment:29 Changed 6 years ago by phoul

Resolution: fixed
Status: assignedclosed

All branches should now be updated.

Marking ticket as fixed, please reopen if I missed something.

comment:30 Changed 3 years ago by isabela

Component: User Experience/TranslationsCommunity/Translations
Note: See TracTickets for help on using tickets.