Opened 5 years ago

Last modified 2 weeks ago

#9145 needs_review defect

Tor Browser for Windows is borked with hardware acceleration enabled (because of gcc?)

Reported by: dope457 Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-crash, fuck-mingw, ff60-esr, TorBrowserTeam201807R
Cc: mcs, sukhbir, jllover Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Podpis problému:

Název události problému: APPCRASH
Název aplikace: firefox.exe
Verze aplikace: 17.0.6.0
Časové razítko aplikace: 386d4380
Název chybného modulu: d2d1.dll
Verze chybného modulu: 6.1.7601.17514
Časové razítko chybného modulu: 4ce7b7aa
Kód výjimky: c0000005
Posun výjimky: 0001f3ba
Verze operačního systému: 6.1.7601.2.1.0.256.1
ID národního prostředí: 1029
Další informace 1: 0a9e
Další informace 2: 0a9e372d3b4ad19135b953a78882e789
Další informace 3: 0a9e
Další informace 4: 0a9e372d3b4ad19135b953a78882e789

Přečtěte si prohlášení o zásadách ochrany osobních údajů online:

http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0405

Pokud není k dispozici Prohlášení o zásadách ochrany osobních údajů online, přečtěte si toto prohlášení offline:

C:\Windows\system32\cs-CZ\erofflps.txt

Child Tickets

Change History (42)

comment:1 Changed 5 years ago by gk

Seems still to be an issue with TBB based on Firefox ESR 24. See: #10531.

comment:2 Changed 4 years ago by cypherpunks

See: #11943
Disabling of direct2d and acceleration doesn't help.

comment:3 Changed 4 years ago by gk

Milestone: Tor: unspecified
Version: Tor: unspecified

comment:4 Changed 4 years ago by arma

This ticket is still open.

Is this the one that we fixed in TBB 3.5rc1?
https://blog.torproject.org/blog/tor-browser-bundle-35rc1-released
"Misc Prefs: Disable layer acceleration to avoid crashes on Windows"

Or was that some other ticket?

comment:5 in reply to:  4 Changed 4 years ago by gk

Resolution: fixed
Status: newclosed

Replying to arma:

This ticket is still open.

Is this the one that we fixed in TBB 3.5rc1?
https://blog.torproject.org/blog/tor-browser-bundle-35rc1-released
"Misc Prefs: Disable layer acceleration to avoid crashes on Windows"

Or was that some other ticket?

No, this one, thanks.

comment:6 Changed 4 years ago by christopher

Started experiencing this bug with an old(ish) install; updated to latest public version (3.6.3) and still crashes.

Workarounds discussed in https://lists.torproject.org/pipermail/tor-talk/2013-June/028564.html work.

I updated my NVidia drivers a couple of weeks ago which is possibly the cause. Currently running 340.52, Direct3D v11 on a GeForce GTX 770. Windows 7 Pro 64-bit.

comment:7 Changed 4 years ago by christopher

Resolution: fixed
Status: closedreopened

comment:8 Changed 4 years ago by cypherpunks

Workarounds discussed in ​https://lists.torproject.org/pipermail/tor-talk/2013-June/028564.html work.

XP Compatible mode? Or you changes prefs yet?
gfx.direct2d.disabled and layers.acceleration.disabled should be set true by default, what they are in your crashing browser?

comment:9 Changed 3 years ago by cypherpunks

Component: Tor bundles/installationTor Browser
Status: reopenedneeds_information

comment:10 in reply to:  description Changed 3 years ago by cypherpunks

Severity: Normal

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:11 Changed 3 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:12 Changed 3 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:13 Changed 3 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:14 Changed 3 years ago by cypherpunks

Keywords: cross-compile added; tbb-3.0 firefox-crash removed
Summary: TBB 3.0a1 crashes on startup on Win7 (TorBrowser has stopped working)Cross compile for windows is borked because mingw, gcc, and Win32 ABI

comment:15 Changed 3 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:16 Changed 3 years ago by cypherpunks

Summary: Cross compile for windows is borked because mingw, gcc, and Win32 ABITor Browser for windows is borked because mingw, gcc, and Win32 ABI

comment:17 Changed 3 years ago by cypherpunks

Keywords: cross-compile removed

comment:18 Changed 3 years ago by mcs

Cc: mcs added
Owner: changed from erinn to tbb-team
Status: needs_informationassigned

comment:19 Changed 3 years ago by mcs

Status: assignedneeds_information

comment:20 Changed 3 years ago by cypherpunks

Status: needs_informationnew
Last edited 2 years ago by cypherpunks (previous) (diff)

comment:21 Changed 3 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:22 Changed 3 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:23 Changed 3 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:24 Changed 2 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:25 Changed 2 years ago by cypherpunks

Keywords: Windows GCC ABI Hardware acceleration added

comment:26 Changed 2 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:27 Changed 2 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:28 Changed 2 years ago by cypherpunks

Keywords: Hardware-acceleration added; Hardware acceleration removed

comment:29 Changed 2 years ago by cypherpunks

Keywords: mingw added

comment:30 Changed 2 years ago by cypherpunks

Keywords: fuck-mingw added; mingw removed

comment:31 Changed 2 years ago by cypherpunks

Keywords: GCC ABI removed
Summary: Tor Browser for windows is borked because mingw, gcc, and Win32 ABITBB 3.0a1 crashes on startup on Win7

comment:32 Changed 2 years ago by cypherpunks

Fuck windows, fuck mingw, and fuck everything near it.

comment:33 Changed 22 months ago by gk

Looking at this f*ck-mingw bug, the GCC ticket (this is actually a GCC bug it seems) is: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=64384.

comment:34 Changed 16 months ago by tom

To add some explicit instructions here as this gets referenced often. For a built browser suffering from the problem, on Windows:

  1. Copy browser/omni.ja twice, once to omni.ja-backup and once to omni.zip
  2. Unzip the zip file using Windows built-in Zip Extractor. ([0] Indicates that other zip programs will not work correctly)
  3. In the extracted omni/ folder, edit default/preferences/firefox.js and add pref("gfx.direct2d.disabled",true);
  4. Repackage the folder by running (in the extracted omni/ folder) zip -qr9XD omni.ja * - I used the cygwin zip package to do this. [0] indicates that other packaging methods will not work.
  5. move the repackages omni.ja over top the original (you have the back up right?!) and test!

I was able to get it running with only gfx.direct2d.disabled - maybe one might need the layers.acceleration.disabled set to true too?

[0] https://developer.mozilla.org/en-US/docs/Mozilla/About_omni.ja_%28formerly_omni.jar%29

comment:35 Changed 5 months ago by cypherpunks

Keywords: Windows Hardware-acceleration removed
Summary: TBB 3.0a1 crashes on startup on Win7Tor Browser for Windows is borked with hardware acceleration enabled (because of gcc?)

Do we really need to enable direct access to hardware for the browser?
Current prefs look pretty well:

Decision Log
HW_COMPOSITING	
disabled by user: Disabled by pref
D3D11_COMPOSITING	
unavailable by default: Hardware compositing is disabled
D3D9_COMPOSITING	
unavailable by default: Hardware compositing is disabled
DIRECT2D	
unavailable by default: Direct2D requires Direct3D 11 compositing
D3D11_HW_ANGLE	
unavailable by default: D3D11 compositing is disabled
disabled by env: D3D11 compositing is disabled

comment:36 Changed 5 months ago by gk

FWIW: tjr is fighting with that over at Mozilla, see: https://bugzilla.mozilla.org/show_bug.cgi?id=1411401.

#25209 is likely a duplicate.

comment:37 Changed 4 weeks ago by gk

Cc: sukhbir added
Keywords: ff60-esr added

https://bugzilla.mozilla.org/show_bug.cgi?id=1411401#c24 is relevant. As we still have users hitting this bug we could think about solving it as Jacek mentioned, especially as I moved to the current mingw-w64 commit to get this fix for free (I did not realize that this was not the case).

Last edited 4 weeks ago by gk (previous) (diff)

comment:38 Changed 4 weeks ago by sukhbir

Status: newneeds_review

For review:

tor-browser-build (sets the CXXFLAGS):

https://github.com/azadi/tor-browser-build-1/tree/bug-9145

Tor Browser (removes the preferences):

https://github.com/azadi/gecko-dev/tree/bug-9145

I tested this on a Windows machine with an earlier build and Tor Browser was indeed crashing when the preferences were enabled (set to false). The new build with the above change does not crash; I verified this for both the 32- and 64-bit versions of Tor Browser.

comment:39 Changed 3 weeks ago by gk

Cc: jllover added

comment:40 Changed 3 weeks ago by gk

Marked #26423 as duplicate.

comment:41 Changed 3 weeks ago by gk

Keywords: TorBrowserTeam201806R added

comment:42 Changed 2 weeks ago by gk

Keywords: TorBrowserTeam201807R added; TorBrowserTeam201806R removed

Moving reviews to July.

Note: See TracTickets for help on using tickets.