Opened 7 years ago

Closed 7 years ago

#9153 closed defect (fixed)

Hype Machine doesn't support SSL, so rule breaks the site

Reported by: cypherpunks Owned by: micahlee
Priority: Medium Milestone: HTTPS-E 3.2.3
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.2.2
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://hypem.com/

The site, by design, serves a lot of third-party content unencrypted, so it doesn't support SSL for mixed-content reasons. Ruleset should probably be rewritten to just exclude the site.

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by cypherpunks

Component: - Select a componentEFF-HTTPS Everywhere
Owner: set to pde

comment:2 Changed 7 years ago by pde

Milestone: HTTPS-E 3.2.3
Owner: changed from pde to micahlee
Status: newassigned
Version: HTTPS-E 3.2.2

comment:3 Changed 7 years ago by MB

Resolution: fixed
Status: assignedclosed

Fixed in d122c11b

comment:4 Changed 7 years ago by fascinated

Resolution: fixed
Status: closedreopened

The commit that marked this 'resolved' doesn't actually address the Hype Machine (hypem.com) issue, fixes something else instead.

Can hypem.com be excluded from the list of services where HTTPS is forced?

I am the site administrator and because we currently use remote sources for audio playback (Soundcloud, Bandcamp, MP3 files) that are not on secure servers, as well as advertising that is not served securely, it is unlikely there is a way to make HTTPS Everywhere work with our site at this time.

If this changes, I am happy to even redirect to HTTPS on our own, as I am a big fan of EFF and the HTTPS-E project, but this is unfortunately not possible now.

comment:5 Changed 7 years ago by zyan

Resolution: fixed
Status: reopenedclosed

Turned off in the 3.5 branch!

Note: See TracTickets for help on using tickets.