Opened 6 years ago

Closed 3 years ago

#9178 closed defect (not a bug)

Tor and Hamachi IP conflict

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-relay hamachi resolve ip
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If I want to host a Relaying point, I have to release the IPv4 address of my Hamachi adapter, otherwise Tor resolves it's IP as my external, so others can't join. I tried to change the adapter order but it didn't help. Also, if I renew my Hamachi IP after Tor set up the relaying and done port checks, it says my external IP changed from <Real external IP> to <Hamachi IP>.
First I used the TBB, but I also downloaded the latest version from git (2.4.14-alpha) and compiled myself, but still got the same problem.
I'm using Win7 x64.

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by nickm

Keywords: tor-relay added; tor removed
Milestone: Tor: unspecified

You might want to try asking help@… . This sounds more like it could be a support thing than a Tor bug, if I understand you right.

comment:2 Changed 3 years ago by nickm

Resolution: not a bug
Severity: Normal
Status: newclosed
Note: See TracTickets for help on using tickets.