Opened 11 years ago

Last modified 11 years ago

#924 closed defect (Fixed)

Bundle installer fails: "The Bill of Materials for this package was not found."

Reported by: torpor Owned by: phobos
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version: 0.2.0.33
Severity: Keywords:
Cc: torpor Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm having the same problem, on the same OS (MacOSX 10.3.9), reported by
Louis in the blog on January 29, 2009: The bundle installer fails to start,
saying:

The Installer package "vidalia-bundle-0.2.0.34-0.1.10-ppc" cannot be
opened.

The Bill of Materials for this package was not found.

My current version was installed from

vidalia-bundle-0.2.0.30-0.1.6-panther.dmg.

The reply to Louis's note in the blog asked what /var/log/install.log
showed. Here are the complete entries from two attempts to run the
installer:

Feb 11 01:10:30 localhost : Vidalia - Tor - Privoxy - Torbutton Bundle Installation Log
Feb 11 01:10:30 localhost : Opened from: /Volumes/vidalia-bundle-0.2.0.34-0.1.10-ppc/vidalia-bundle-0.2.0.34-0.1.10-ppc.mpkg
Feb 11 01:10:30 localhost : Hardware Model: PowerMac4,4 @ 999 MHz, 768 MB
Feb 11 01:10:30 localhost : Running OS Build: 7W98
Feb 11 01:10:30 localhost : Installer Language: English
Feb 11 01:11:12 localhost : Vidalia - Tor - Privoxy - Torbutton Bundle Installation Log
Feb 11 01:11:12 localhost : Opened from: /Volumes/vidalia-bundle-0.2.0.34-0.1.10-ppc/vidalia-bundle-0.2.0.34-0.1.10-ppc.mpkg
Feb 11 01:11:12 localhost : Hardware Model: PowerMac4,4 @ 999 MHz, 768 MB
Feb 11 01:11:12 localhost : Running OS Build: 7W98
Feb 11 01:11:12 localhost : Installer Language: English

Here is Louis's original note:

Re: Installation latest version of Tor
On January 29th, 2009 Louis (not verified) said:

I need some assistance please. I am a basic computer user but I have
been able to install Tor which I have been using daily for months now.
My OS is MacOsx Panther 10.3.9 and the Tor bundle installed is 0.2.0.31.
The OS is being operated from an external HD.

I am no longer able to upgrade to the latest Tor versions (0.2.0.33)
because as soon as I open the installer package of the new version I get
the error message:

The Installer package "vidalia-bundle - 0.2.0.33-0.10-ppc" cannot be
opened.

The Bill of Materials for this package was not found.

I have tried several times with the same result. I have tried moving the
old Tor, Privoxy and Vidalia folders to the trash but I still get the error
message!. Am I doing something wrong? I have always upgraded to
new stable versions of Tor this way.

Thank you in advance for your help.

Louis

[Automatically added by flyspray2trac: Operating System: OSX 10.3 Panther]

Child Tickets

Change History (5)

comment:1 Changed 11 years ago by phobos

Well, my ppc build machine has the same problem, so the problem is recreated. Working on a solution....

comment:2 Changed 11 years ago by phobos

The problem appears to have been caused by the gcc2004 update I applied to the build machine. The build machine
is being rebuilt, since one can't remove just the gcc2004 update. I expect to have new packages after the machine is
rebuild from scratch this weekend.

comment:3 Changed 11 years ago by phobos

New bundles and expert packages are now available. These work on two different OS X 10.3.9 machines without any issues.

comment:4 Changed 11 years ago by arma

Can we close this bug then? I will assume so unless I hear otherwise.

comment:5 Changed 11 years ago by arma

flyspray2trac: bug closed.

Note: See TracTickets for help on using tickets.