Opened 6 years ago

Closed 6 years ago

#9255 closed defect (fixed)

(py)obfsproxy doesn't support --version

Reported by: arma Owned by: asn
Priority: Medium Milestone:
Component: Archived/Obfsproxy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

$ /usr/bin/obfsproxy --version
usage: obfsproxy [-h] [--log-file LOG_FILE]
                 [--log-min-severity {error,warning,info,debug}] [--no-log]
                 [--no-safe-logging]
                 {managed,obfs2,dummy,obfs3,b64} ...
obfsproxy: error: too few arguments

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by asn

Resolution: fixed
Status: newclosed

Fixed. Please reopen if you don't like or if you find bugs:
https://gitweb.torproject.org/pluggable-transports/obfsproxy.git/commitdiff/f2e307cc50238b46380f7c57391ac2a06efab266

The version string actually comes from Brian's versioneer script [0], and it's the output of git describe --tags --dirty --always.

[0]: https://github.com/warner/python-versioneer

Note: See TracTickets for help on using tickets.