Opened 6 years ago

Closed 6 years ago

#9295 closed defect (fixed)

Recent tor regression: config_get_assigned_option(): Bug: src/or/confparse.c:591

Reported by: atagar Owned by:
Priority: High Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client 023-backport
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi Nick. As spotted by weasel stem's integ tests are presently busted. The issue looks to be a recent regression with password authentication. While I was looking into this I realized that '--hash-password' no longer works. Good chance it's related to whatever the tests are choking on. :)

atagar@morrigan:~/Desktop/stem$ /home/atagar/Desktop/tor/tor/src/or/tor --hash-password pw
Jul 18 19:10:49.803 [notice] Tor v0.2.5.0-alpha-dev (git-f45e1fbd5b25735c) running on Linux with Libevent 1.4.13-stable and OpenSSL 0.9.8o.
Jul 18 19:10:49.803 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jul 18 19:10:49.803 [notice] This version is not a stable Tor release. Expect more bugs than usual.
Jul 18 19:10:49.806 [err] config_get_assigned_option(): Bug: src/or/confparse.c:591: config_get_assigned_option: Assertion options && key failed; aborting.
src/or/confparse.c:591 config_get_assigned_option: Assertion options && key failed; aborting.
Aborted

Cheers! -Damian

Child Tickets

Change History (4)

comment:1 Changed 6 years ago by nickm

Keywords: tor-client 023-backport added
Milestone: Tor: 0.2.4.x-final

comment:2 Changed 6 years ago by nickm

This appears to be a problem in 0.2.3 too. :p

comment:3 Changed 6 years ago by nickm

Except, apparently not. I guess I was in the wrong directory.

comment:4 Changed 6 years ago by nickm

Resolution: fixed
Status: newclosed

Merged a trivial fix that works for me. This was a bugfix on the #9122 fix. Please reopen if I didn't get it?

Note: See TracTickets for help on using tickets.