Opened 6 years ago

Closed 6 years ago

#9297 closed defect (worksforme)

Error while compiling the latest git (seccomp2-related)

Reported by: cypherpunks Owned by:
Priority: High Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

  • Debian unstable 32
  • gcc version 4.8.1 (Debian 4.8.1-6)

[In file included from src/common/sandbox.c:30:0:
src/common/sandbox.c:117:5: error: ‘NR_accept4’ undeclared here (not in a function)

SCMP_SYS(accept4),

src/common/sandbox.c:133:5: error: ‘NR_setsockopt’ undeclared here (not in a function)

SCMP_SYS(setsockopt),

]

Child Tickets

Attachments (1)

9297.patch (585 bytes) - added by nickm 6 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by nickm

Keywords: tor-client added
Milestone: Tor: 0.2.5.x-final
Priority: normalmajor

comment:2 Changed 6 years ago by nickm

Strange that we haven't run into that! What version of libseccomp do you have?

Changed 6 years ago by nickm

Attachment: 9297.patch added

comment:3 Changed 6 years ago by nickm

I've attached a possible fix. Does it work for you?

comment:4 in reply to:  2 Changed 6 years ago by cypherpunks

Replying to nickm:

What version of libseccomp do you have?

The one shipped with unstable - libseccomp1-1.0.1-2

I've attached a possible fix. Does it work for you?

It doesn't work ...

comment:5 Changed 6 years ago by cypherpunks

Solved by installing a local copy of the latest version of libseccomp (v2.1.0)

comment:6 Changed 6 years ago by nickm

Summary: Error while compiling the latest gitError while compiling the latest git (seccomp2-related)

comment:7 Changed 6 years ago by nickm

Resolution: worksforme
Status: newclosed

Closing as worksforme, since I'm probably not going to be able to track this down unless somebody is actively experiencing it. Please reopen if this bug happens for you.

Note: See TracTickets for help on using tickets.