Opened 4 years ago

Closed 4 years ago

#9298 closed defect (duplicate)

Recent tor regression: segfault on startup

Reported by: atagar Owned by:
Priority: High Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After #9295 I tried rerunning the integ tests with a password authenticated tor instance but no joy. Four of the last five times I started tor with a HashedControlPassword it segfaulted...

atagar@morrigan:~/Desktop/stem$ cat ~/.tor/torrc
SocksPort 0
ControlPort 9051
Exitpolicy reject *:*
FetchUselessDescriptors 1
DisableDebuggerAttachment 0

# password: pw
HashedControlPassword 16:6175C1B2491BD88D605B5F65597E1CD3A7336D5715686DE1ED2145F2E6

atagar@morrigan:~/Desktop/stem$ /home/atagar/Desktop/tor/tor/src/or/tor -f /home/atagar/.tor/torrcJul 19 08:47:03.654 [notice] Tor v0.2.5.0-alpha-dev (git-e1d3b444952d861e) running on Linux with Libevent 1.4.13-stable and OpenSSL 0.9.8o.
Jul 19 08:47:03.655 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jul 19 08:47:03.655 [notice] This version is not a stable Tor release. Expect more bugs than usual.
Jul 19 08:47:03.655 [notice] Read configuration file "/home/atagar/.tor/torrc".
Jul 19 08:47:03.667 [notice] Opening Control listener on 127.0.0.1:9051
Jul 19 08:47:03.000 [notice] Not disabling debugger attaching for unprivileged users.
Jul 19 08:47:03.000 [notice] Parsing GEOIP IPv4 file /usr/local/share/tor/geoip.
Jul 19 08:47:04.000 [notice] Parsing GEOIP IPv6 file /usr/local/share/tor/geoip6.
Jul 19 08:47:04.000 [notice] Your OpenSSL version seems to be 0.9.8o. We recommend 1.0.0 or later.
Jul 19 08:47:05.000 [notice] This version of Tor (0.2.5.0-alpha-dev) is newer than any recommended version, according to the directory authorities. Recommended versions are: 0.2.2.39,0.2.3.24-rc,0.2.3.25,0.2.4.5-alpha,0.2.4.6-alpha,0.2.4.7-alpha,0.2.4.8-alpha,0.2.4.9-alpha,0.2.4.10-alpha,0.2.4.11-alpha,0.2.4.12-alpha,0.2.4.13-alpha,0.2.4.14-alpha,0.2.4.15-rc
Jul 19 08:47:09.000 [notice] We now have enough directory information to build circuits.
Jul 19 08:47:09.000 [notice] Bootstrapped 80%: Connecting to the Tor network.
Jul 19 08:47:10.000 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Jul 19 08:47:10.000 [notice] We weren't able to find support for all of the TLS ciphersuites that we wanted to advertise. This won't hurt security, but it might make your Tor (if run as a client) more easy for censors to block.
Jul 19 08:47:10.000 [notice] To correct this, use a more recent OpenSSL, built without disabling any secure ciphers or features.
Jul 19 08:47:11.000 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Jul 19 08:47:13.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Jul 19 08:47:13.000 [notice] Bootstrapped 100%: Done.
Segmentation fault

This is with tor commit e1d3b44.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by nickm

I think this is #9296. I just merged a fix for that; let me know if this goes away?

comment:2 Changed 4 years ago by nickm

  • Milestone set to Tor: 0.2.5.x-final

comment:3 Changed 4 years ago by atagar

  • Resolution set to duplicate
  • Status changed from new to closed

Swapped to d2cd0df and tor started successfully a couple times. Integ tests for password authentication also passed. Thanks!

Note: See TracTickets for help on using tickets.