Opened 10 years ago

Last modified 10 years ago

#931 closed defect (Works for me)

Socks Options in Torbutton 1.2 missed!

Reported by: Georgee Owned by:
Priority: Low Milestone:
Component: Applications/Torbutton Version: 1.2.0
Severity: Keywords:
Cc: Georgee, arma, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On my Sytsem, the only way to use Privoxy and tor is to use SOCKS v4.
But Torbutton uses SOCKS v5 Option, and there is no way to change it to SOCKS v4.
Please add this possiblity in further versions of torbutton, so that I can use it to.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Attachments (2)

torbutton-1.2.0-dev.xpi.10 (291.7 KB) - added by mikeperry 10 years ago.
Add Socks version option.
config.txt (34.2 KB) - added by Georgee 10 years ago.
My Privoxy config.txt file

Download all attachments as: .zip

Change History (23)

comment:1 Changed 10 years ago by mikeperry

I'm confused. Privoxy provides an http proxy, not a socks one...

comment:2 Changed 10 years ago by Georgee

Im too.
The only way to run Privoxy, is to insert in the main configuration the therm:
forward-socks4a / 127.0.0.1:9050 .
So, I must set the Proxyoptions in firefox:
SOCKS-HOST:127.0.0.1 Port 9050 (that does torbutton correct), but I also have to use the option SOCKS v4 (which is not used in torbutton, so I must change from SOCKS v5 to SOCKS v4 manually.
But there is no option in Ttrbutton to do that, so this is the option I missed in torbutton.

comment:3 Changed 10 years ago by mikeperry

If you are using privoxy, it listens on 127.0.0.1 port 8118 as an HTTP and HTTPS proxy, and
the default settings of torbutton should work fine.

comment:4 Changed 10 years ago by Georgee

Fine, Privoxy should and torbutton will,
have you read my messages?
Privoxy don't and torbutton don't help.
Please add this options, so that iI can use torbutton sucessfully.

comment:5 Changed 10 years ago by mikeperry

Your messages aren't very clear. If you use privoxy there is no need to set a socks proxy in torbutton.
You set an HTTP proxy instead (which is the default).

From what I can decipher out of your messages, it sounds like you have a privoxy problem, not a Torbutton problem.

However, if you are trying to say that you do not want to use privoxy at all, then the default SOCKS settings for
Torbutton will use Tor as a SOCKS v5 proxy instead of SOCKS v4. This works fine for me and is supported, so even
if this is your problem, I still don't understand why you think it doesn't work.

What does https://check.torproject.org say when you visit it, and can you paste your exact proxy settings for all
protocols here?

comment:6 Changed 10 years ago by mikeperry

Hrmm, let me guess with a shot in the dark:

You don't want to use Privoxy, and you don't want to use Tor. You want to use Torbutton with some other SOCKS v4 proxy
that does not support SOCKS v5. Is that the case?

comment:7 Changed 10 years ago by Georgee

No, I want to use Privoxy and I want to use Tor. But Privoxy don't work succesfully with the default setting son my system. So I seeked in the web, what I can do. The only way that works on my system I have found, was to insert: forward-socks4a / 127.0.0.1:9050 .
With this option, Privoxy run. But the way tro use it in Firefox, is to set the Proxy Settings to SOCKS v4.
Ok, now I can run Firefox, Privoxy and Tor, but not Torbutton. I have to set the Proxy Settings manually and have to activate/disactivate the Proxysettings manually.
So, my next step is to write to you, that you will add the Socks Setting Option to Torbutton.
I'am no expert, I do not really know, how Privoxy and Tor works, and what else I can do, to make them run. I have found this way, it works, but I need this option in Torbutton.
Why do you don't want to do this? Is it to difficult or are there other reasons.
Than show me a way to rum Privoxy on my system with SOCK v5 Settings. I don't know, why it don#t run on my system, and what I can do. (Proxy- whats this, how works it and will it bite me, if I do wrong?)

comment:8 Changed 10 years ago by mikeperry

The socks v5 setting in firefox has nothing to do with your privoxy configuration file.

In fact, since you are using privoxy, firefox won't even touch Tor as a socks proxy at all (despite
the fact that it has a setting for a socks proxy).

Leave the setting as SOCKS v5 in firefox, and visit https://check.torproject.org with Torbutton installed,
enabled, and configured with its default proxy settings of SOCKS v5 and HTTP+HTTPS proxy. Then let me know
if https://check.torproject.org says you are successfully using Tor.

comment:9 Changed 10 years ago by Georgee

That was originally, what I tried first. The result: https://check.torproject.org say to me, You are not using Tor.
And Privoxy doesn't work (the icon don't change, no rotating qartercircle).
This was the reason, why I searched the internet, and the only way I found, was the way I've write above.
Don't no why, don't know how, but this works, and to this time it's the only way I know which works.

Changed 10 years ago by mikeperry

Attachment: torbutton-1.2.0-dev.xpi.10 added

Add Socks version option.

comment:10 Changed 10 years ago by mikeperry

ok, try the snapshot in the attachments tab. It should add a SOCKS v4 option under custom settings.

comment:11 Changed 10 years ago by Georgee

thank you, I've tried it but:

  • my firefox wanted to be updating to torbuttun 1.2.0 and
  • the settings are the same as the manually done, but it doesn't work, I don't know why and I'am very confused.

comment:12 Changed 10 years ago by mikeperry

Yeah, I suspect you have some other problem with your Tor configuration.. Maybe you still have an HTTP proxy
specified that is not working properly.

comment:13 Changed 10 years ago by Georgee

But how and why? I have nothing done than to install the vidalia package from your page. And have insert the SOCKs 4 option, after I have mentiend, that it does not work.
And if I do the same settings manually, Tor and Privoxy works, but whwn I use torbutton, it doesn't.
So how can I have specified a not properly working HTTP proxy?

comment:14 Changed 10 years ago by mikeperry

Please hit the torbutton button "Restore defaults", then test it again. If it still doesn't work, set
whatever custom Tor proxy settings you think might be necessary. If it still does not work, please copy
the name and value of every <b>bold</b> setting under about:config with a filter of "network.proxy"
and post it here.

Please also attach your privoxy config file in the attachments tab to this bug. It should be
in /etc/privoxy/config on Linux.

comment:15 Changed 10 years ago by Georgee

OK, here are the bold FF settings with network.proxy filter which works (WINXPprof, FF 3.0.7, Vidalia 0.1.10, Tor 0.2.1.12-alpha (r18423), QT 4.4.3, Privoxy 3.0.6):
network.proxy.http;127.0.0.1
network.proxy.http_port;8118
network.proxy.socks;127.0.0.1
network.proxy.socks_port;9050
network.proxy.socks_remote_dns;true
network.proxy.socks_version;4
network.proxy.ssl;127.0.0.1
network.proxy.ssl_port;8118

Changed 10 years ago by Georgee

Attachment: config.txt added

My Privoxy config.txt file

comment:16 Changed 10 years ago by mikeperry

Wait, you say this works now? Is this with torbutton?

I need you to give me the bold settings while Torbutton is enabled.

comment:17 Changed 10 years ago by Georgee

No, it's without torbutton. And after autoupdate from torbutton to 1.2.1 it only works, after I have uninstall torbutton.

The bold settings with enabled torbutton 1.2.1 are the same as above, but additional there is the setting:
network.proxy.type;1
that's the only different in proxy settings, but with this setting, it doen't work on my system.

comment:18 Changed 10 years ago by mikeperry

Hrmm, I was under the impression network.proxy.type needs to be set to 1 for you to use
your proxy settings at all.

If you set it to 1 without torbutton, does https://check.torproject.org still say you
are using Tor?

comment:19 Changed 10 years ago by Georgee

Yes, it say, that I'am using Tor.
But, maybe it's an problem with Privoxy?
After I have installed the Vidalia Bundle, and started it first, I get an error warning in Privoxy and I must restart it manual. I also have to deactivate in the vidalia settings the option: start proxy when Vidalia starts, otherwise I get the error message: Apr 04 09:46:30 Privoxy(00000e18) Fatal error: can't check configuration file 'config.txt': (error number 2).
Maybe this will help you, to help me.

comment:20 Changed 10 years ago by mikeperry

This is no longer under the same topic as the original bug and is wandering into tech support
land. I'm going to close this. Please ask help questions on irc in #tor on irc.oftc.net.

comment:21 Changed 10 years ago by mikeperry

flyspray2trac: bug closed.
Scrubbing tech support style bug

Note: See TracTickets for help on using tickets.