Opened 5 years ago

Closed 11 months ago

#9313 closed defect (wontfix)

RunAsDaemon=1 reported as "Unneeded torrc entry"

Reported by: amontero Owned by: erinn
Priority: Low Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Normal Keywords: needs-triage
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

arm version 1.4.5.0 (released April 28, 2012)
Tor v0.2.3.25 (git-3fed5eb096d2d187)
Both under Ubuntu Precise.

arm complains:

[ARM_NOTICE] Unneeded torrc entries found. They've been highlighted in blue on the torrc page.
   - entry matches its default value: RunAsDaemon (line 4)

I have RunAsDaemon set to 1, and docs at https://www.torproject.org/docs/tor-manual.html.en say (Default: 0).

Child Tickets

Change History (8)

comment:1 Changed 5 years ago by atagar

Are you on debian or ubuntu? As I recall the tor deb alters the defaults from what is documented in the man page - it might be tripping on that.

comment:2 Changed 5 years ago by atagar

I believe this is what it uses, in which it indeed defaults RunAsDaemon to true...

https://gitweb.torproject.org/debian/tor.git/blob/HEAD:/debian/tor-service-defaults-torrc

Definitely confusing, though not an issue with arm.

comment:3 Changed 5 years ago by hsn

just ignore RunAsDaemon entry. Same error is in FreeBSD

comment:4 Changed 5 years ago by amontero

I'm on Ubuntu. I tried changing defaults in tor-service-defaults-torrc and problem disappears. Definitely a packaging issue, I didn't thought on this.

Found also similar issues #4602 and #2362.

Thank you.

comment:5 Changed 5 years ago by atagar

Component: armTor bundles/installation
Owner: changed from atagar to erinn
Priority: normalminor

I'm not quite sure why this is happening on FreeBSD, there could be custom defaults in its port but I haven't checked. This isn't the same issue as #4602 or #2362 (those were arm and tor bugs), in this case the issue is simply that tor's man page doesn't match what's on debian.

I'm going to reassign this to the packaging component. Peter, could we have a custom man page on debian that reflects the defaults in the deb?

comment:6 Changed 4 years ago by erinn

Keywords: needs-triage added

comment:7 Changed 13 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:8 Changed 11 months ago by arma

Resolution: wontfix
Status: newclosed

I'm going to close this ticket as no longer relevant now that arm doesn't exist anymore.

If somebody wants to find the same bug in nyx, please open a new ticket. :)

Note: See TracTickets for help on using tickets.