Opened 6 years ago

Closed 3 years ago

#9344 closed defect (fixed)

Cannot set tor browser as default browser nor open any link through it (even command-line)

Reported by: ksana Owned by: tbb-team
Priority: High Milestone: TorBrowserBundle 2.3.x-stable
Component: Applications/Tor Browser Version: Tor: 0.2.3.25
Severity: Normal Keywords: tbb-firefox-patch
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm using linux and trying to make tor as default browser.
But running commands like

/home/user/tor-browser_ru/App/Firefox/firefox -no-remote -profile /home/user/tor-browser_ru/Data/profile -new-tab https://ya.ru

gives me msgbox with «Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.»

I don't understand you at this point if that is not a bug. Because the main purpose of using tor-browser is to make internet-surfing safe. And openning links from your messengers in tor-browser (i.e. using it by default) seems to me an obviously logical solution.

Ksana.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by cri

A solution was proposed at http://tor.stackexchange.com/a/1109
Including a patch for the TBB 3.5 startup script: https://gist.github.com/gunesacar/3a49ef6a9daa546b2330#file-start-tor-browser-patch

Can any TOR developer please comment on the pro/cons of this proposal?

comment:2 Changed 5 years ago by erinn

Keywords: tbb-firefox-patch added

comment:3 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser
Owner: changed from mikeperry to tbb-team

comment:4 Changed 3 years ago by cypherpunks

Resolution: fixed
Severity: Normal
Status: newclosed

Fixed long ago. Duplicates: #15981 #15185 #15370.

Note: See TracTickets for help on using tickets.