Opened 6 years ago

Closed 5 years ago

#9377 closed enhancement (duplicate)

Add more unittests for and logging to descriptor parsers

Reported by: sysrqb Owned by: isis
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords: bridgedb-unittests, bridgedb-parsers
Cc: isis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We need higher test coverage and more logging that will help us troubleshoot subtle bugs.

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by isis

Keywords: bridgedb-unittests bridgedb-parsers added
Owner: set to isis
Status: newassigned

Parts of the logging for this are fixed in commits 54c5063cae2057a92e813a314fec78da2a7960d4 and 6673109c8bf0da40123e53be3d1b37696ee503ab.

comment:2 Changed 5 years ago by isis

Resolution: duplicate
Status: assignedclosed

This is now rather irrelevant, due to the work being done for #9380. (I will require that the new parsers have >90% coverage before merging.)

Closing as a duplicate of #9380.

Note: See TracTickets for help on using tickets.