Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9395 closed defect (not a bug)

Using the TBB port 9150 exclusively breaks Torbirdy with a regular Tor install.

Reported by: schulze Owned by: tagnaq
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Since version 0.1.1 Torbirdy uses port 9150, as used by the TBB. Port 9050
is still used by most other Tor installations, e.g. the Debian package provided by the Tor project. Using different ports allows to run a TBB next to a regular Tor install.

https://trac.torproject.org/projects/tor/wiki/torbirdy#SetupSteps mentions that one should

make sure Tor is running with default client settings (SocksPort is
listening on 127.0.0.1:9150)

but ideally Torbirdy should also check the default default port 9050.

This will probably also be usefull, when #3948 is implemented and some newer TBBs use 9050 again.

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by tagnaq

Owner: changed from ioerror to tagnaq
Status: newassigned

Hi,

thanks for your input.

My initial documentation [1] was meant to be used for a "system tor" setup. "system tor" is a tor instance that automatically starts as soon as the system boots (or the user logs in).

Apparently Sukhbir changed it [2] to use port 9150 (default SocksPort setting in current TBB).

So the question is: Do we want Windows users to use a Vidalia Bundle* (= system tor) or TBB to get a running Tor instance?

I'm in favor of a system tor (via vidalia bundle) because the vidalia interface of Vidalia Bundles has the setting 'Start Vidalia when my system starts' - a setting which is not available in TBB's vidalia.

The Vidalia Bridge Bundle does start a SOCKS listener on *9050*.

*) we ask Win/OSX users to download the 'vidalia bundle', but the 'vidalia bundle' seems no longer available, now there are the following bundles available: 'Vidalia Bridge Bundle', 'Vidalia Relay Bundle' and 'Vidalia Exit Bundle' but no 'Vidalia Bundle' (client only) as there was ones.

[1] https://trac.torproject.org/projects/tor/wiki/torbirdy?version=22#SetupSteps

[2] https://trac.torproject.org/projects/tor/wiki/torbirdy?action=diff&version=46&old_version=45

comment:2 Changed 4 years ago by schulze

But this is not just a Windows problem. If somebody installs Tor on Linux using his distributions own packages (or the Tor projects deb/rpm repository) he will get a Tor configured to listen on 9050.
If the user doesn't fix his torrc manually, Torbirdy will fail to connect to the network.

I guess this is not too much of a problem, because most people use TBB as the version of Tor recommended on https://www.torproject.org/download/, but it will be for some.

comment:3 Changed 4 years ago by tagnaq

Resolution: not a bug
Status: assignedclosed

Regardless of OS, I'm aiming to have the documentation (and Torbirdy) point to SocksPort *9050* in the near future (if you are interested you might follow #8909 / #8910).

Currently, our documentation clearly states that Torbirdy expects a SocksPort on port 9150.
Our documentation does *not* say 'TorBirdy supports tor on SocksPort 9050', but because we should aim towards working with default configs we will do so - hopefully - in the near future.

comment:4 Changed 4 years ago by sukhbir

See also: #8936.

Note: See TracTickets for help on using tickets.