Opened 6 years ago

Closed 6 years ago

#9404 closed defect (not a bug)

BridgeDB will sometimes return no obfs2 or obfs3 bridges over html

Reported by: mttp Owned by: isis
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords:
Cc: isis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am unable to reproduce this with any regularity, but I have seen it happen twice now. Sometimes when you visit https://bridges.torproject.org/bridges you will only recieve standard bridges and no obfs2 or obfs3 bridges. This is especially problematic if you are coming from a fixed IP address (e.g. not tor) and need an obfsproxy transport, since you will then have to wait some length of time until your new request for bridges will get you a new set of bridges.

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by asn

I also see the same behavior. I haven't been getting obfsbridges off BridgeDB for a while.

comment:2 Changed 6 years ago by isis

mrphs reported in #tor-dev that the email responder is still able to give PT bridges, but not the HTTPS interface.

comment:3 Changed 6 years ago by sysrqb

I'm finishing #8614 instead of debugging this and #9626.

comment:4 Changed 6 years ago by isis

Owner: changed from sysrqb to isis
Status: newassigned

I haven't seen this bug in quite some time now, and mixed types of bridges are no longer given by default. With #9127 done there will be an interface to select different types.

Closing as "not a bug", if this behaviour is still present feel free to reopen.

comment:5 Changed 6 years ago by isis

Resolution: not a bug
Status: assignedclosed
Note: See TracTickets for help on using tickets.