Opened 6 years ago

Closed 3 years ago

#9434 closed defect (fixed)

Tech Evangelism - ip-check.info showed different IPs for FTP and HTTPS

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The test of TBB showed different ips for ftp and https.
After I put Vidalia's socks address into the ftp field of torbutton and did the test again I got only one ip address. What's wrong with the tor browser bundle? Jondo developers claim that users should add the proxy into all fields of the browser. But it is impossible to put socks proxy of TBB into http field because Tor Browser won't work in this case.

Child Tickets

Attachments (2)

screenshot2.jpg (223.3 KB) - added by cypherpunks 6 years ago.
two different IPs
Screenshot1.jpg (224.2 KB) - added by cypherpunks 6 years ago.
one IP after adding Vidalia's socks address into the ftp field of TorButton

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by cypherpunks

Attachment: screenshot2.jpg added

two different IPs

Changed 6 years ago by cypherpunks

Attachment: Screenshot1.jpg added

one IP after adding Vidalia's socks address into the ftp field of TorButton

comment:1 Changed 6 years ago by arma

Priority: criticalnormal

Are you in Russia? It looks like both the IP addresses in your "two IPs" screenshot are Tor relays. So the website you're testing with is confused.

In any case, you should leave the TBB proxy settings alone. Setting your ftp proxy to be your socks proxy doesn't make any sense.

comment:2 Changed 6 years ago by cypherpunks

The jondo team has given the reply that there is nothing wrong with TorBrowser.

It is a problem of their IP-check to get the information about new Tor servers just in time. Time by time it takes a few hours until our IP-check will get the IP address of a new Tor server.

If the IP addresses of FTP and HTTP/HTTPS are not identically (this is possible, if the HTTP exit node doesn't support FTP) and the IP address of the Tor exit for FTP is not known to our IP-check, you will get the result above.

They are working on this issue. It is not a bug of TorBrowser.

comment:3 Changed 6 years ago by cypherpunks

Which actions do we need to take? Does it make any sense to install a http proxy like squid or privoxy and put its local address to the ftp field?

comment:4 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:5 Changed 3 years ago by bugzilla

Keywords: ftp ip leak tbb-torbutton removed
Milestone: TorBrowserBundle 2.3.x-stable
Resolution: fixed
Severity: Normal
Status: newclosed
Summary: Ftp ip leaks from TBBTech Evangelism - ip-check.info showed different IPs for FTP and HTTPS
Version: Tor: unspecified
Note: See TracTickets for help on using tickets.