Opened 7 years ago

Closed 7 years ago

#9435 closed defect (fixed)

OS X TBB 2.3.25-11 doesn't set package version correctly?

Reported by: arma Owned by: erinn
Priority: Medium Milestone: TorBrowserBundle 2.3.x-stable
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://blog.torproject.org/blog/new-tor-browser-bundles-firefox-1708esr#comment-33395 reports:

"""
The 32-bit Mac (TorBrowser-2.3.25-11-osx-i386-en-US.zip) and 64-bit Mac (TorBrowser-2.3.25-11-osx-x86_64-en-US.zip) versions of TBB appear to have their package version number set incorrectly.

Unziping and doing a Finder Get Info on TorBrowser_en-US.app in 32-bit Mac TBB reveals:

Created: August 8, 2013 9:36 AM
Modified: August 8, 2013 9:36 AM
Version: 2.3.25-10
Copyright: Tor Browser Bundle 2.3.25-10 Copyright 2010, 2011, 2012, 2013 The Tor Project

Similarly, 64-bit Mac TBB 2.3.25-11 reveals:

Created: August 8, 2013 9:41 AM
Modified: August 8, 2013 9:41 AM
Version: 2.3.25-10
Copyright: Tor Browser Bundle 2.3.25-10 Copyright 2010, 2011, 2012, 2013 The Tor Project

Note that for both the Finder reports 2.3.25-10, not 2.3.25-11. However, the FireFox version reported by the browser included in both is 17.0.8, so Mac TBB 2.3.25-11 doesn't actually contain 2.3.25-10.
"""

Looks like there's some other value in the build process that you were supposed to increment?

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by arma

Cc: mikeperry added

comment:2 Changed 7 years ago by erinn

Resolution: fixed
Status: newclosed

Fixed it 9ab5820d0 in torbrowser.git. Going out with the new release today.

Note: See TracTickets for help on using tickets.