Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9438 closed defect (fixed)

TBB 3.0a3 "Tor Network Settings" page blank for some Windows users

Reported by: arma Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: tbb-3.0, tbb-usability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://blog.torproject.org/blog/tor-browser-bundle-30alpha3-released#comment-33380 says
"""
For me (on Windows 7), on running Start Tor Browser.exe, the Tor Network Settings box appears, but it is empty.

It doesn't go into a "Not Responding" state, I can move it, resize it etc, but it's completely empty and nothing happens after this point.
"""

https://blog.torproject.org/blog/tor-browser-bundle-30alpha3-released#comment-33413 appears to report the same thing.

Child Tickets

Attachments (1)

0001-setting-layers.acceleration.disabled-to-true-to-fix-.patch (1.0 KB) - added by gk 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by cypherpunks

Resolution: fixed
Status: newclosed

This is known, Mike is just forgetting! Add these lines to prefs.js, hard-code them:

user_pref("gfx.direct2d.disabled", true);
user_pref("layers.acceleration.disabled", true);

Fixed and done. Mike was the one who first suggested this, and I tried it, and it worked, and I told him about about it, but it fell off his plate?

comment:2 Changed 6 years ago by cypherpunks

Resolution: fixed
Status: closedreopened

comment:4 Changed 6 years ago by arma

Sherief opened #9838 which appears to be the same issue?

comment:5 Changed 6 years ago by mikeperry

If this is specific to non-English languages this smells more like #9144.

Does anyone experience this with English?

Do the prefs actually help? One of them is already set.

comment:6 Changed 6 years ago by gk

Status: reopenedneeds_review

Setting 'layers.acceleration.disabled' to 'true' as well.

comment:7 Changed 6 years ago by mikeperry

Merged this. I'm surprised it works, given #9144. But I guess we'll use it for a while.

Sad to disable rendering acceleration for everyone. We should revisit this later and/or see if it only applies to Windows users. Maybe around FF24, I guess..

comment:8 Changed 6 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

comment:9 Changed 6 years ago by joebt

How is this fixed? For 3.0a4 in Vista x64, I'm still having problem of an empty browser window opening, w/ nothing but "Tor Network Settings" shown in L corner of Nav bar. Only other elements displayed are the screen resizing buttons - upper R corner.

It's not in a "not responding" state - just an empty browser w/ no toolbar / icons.

The suggestions to add entries below, to prefs.js did fix the problem but there aren't any released versions (I've found) w/ this fix, show why is it not "will be fixed in 3.x.x, instead of Fixed?

user_pref("gfx.direct2d.disabled", true);
user_pref("layers.acceleration.disabled", true);

Last edited 6 years ago by joebt (previous) (diff)
Note: See TracTickets for help on using tickets.