Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#9469 closed defect (fixed)

Broken links in Google Maps

Reported by: zyan Owned by: zyan
Priority: High Milestone:
Component: HTTPS Everywhere/HTTPS Everywhere: Chrome Version:
Severity: Keywords: google maps
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Reported by email:

"""

For some time in Chrome (on Windows) if I try to follow a Google Map place
of interest link: e.g. More Info, or even going to the featured businesses
web site direct, I'd get an Error 400 break.

Finally found a forum with lots saying they had this problem:

https://productforums.google.com/forum/?hl=en#!topic/maps/HFy1uLVh9x4

Then (today) someone posted the fix: disable HTTPS Everywhere. And it
worked.

Hopefully you can fix and let us know on that forum thread (I won't be going
back to enable and test often, so HTTPS-E is now off for me L)

"""

I put this in HTTPS Everywhere instead of HTTPS Everywhere chrome because someone in the Google forum reported the same bug in FF19/20.

Child Tickets

Change History (10)

comment:1 Changed 6 years ago by zyan

I couldn't reproduce this in FF23 or Chrome 23.0.1271.64 with https-e 3.2.4

comment:2 in reply to:  1 Changed 6 years ago by zyan

Replying to zyan:

I couldn't reproduce this in FF23 or Chrome 23.0.1271.64 with https-e 3.2.4

s/3.2.4/3.3.1, my bad.

comment:3 Changed 6 years ago by zyan

Resolution: fixed
Status: newclosed

Closed because Google seems to have fixed this.

comment:4 Changed 6 years ago by realityexists

Resolution: fixed
Status: closedreopened

This has been happening to me for a long time and still happens.

Google Chrome 29.0.1547.62 m, HTTPS Everywhere 2013.8.17

Example URL: http://maps.google.com/local_url?dq=Sonic+Drive-In&q=https://plus.google.com/103166861297199328539/about%3Fhl%3Den&s=ANYYN7lSqaxtMAqycKtg72KIPLxuX8fuLQ&dtab=2

comment:5 Changed 6 years ago by arma

Component: EFF-HTTPS EverywhereHTTPS Everywhere: Chrome

comment:6 Changed 6 years ago by pde

Resolution: fixed
Status: reopenedclosed

This seems to be unbroken for me now. I wonder if someone at Google finally noticed our emails complaining about it....

comment:7 Changed 6 years ago by realityexists

Error 400 is fixed, but I still get a blank page for some links. Eg. go to https://maps.google.com/?ll=40.778462,-103.095703&spn=1.1418,1.782532&t=m&z=9 and click on "North Sterling State Park", then "1 review". A new tab opens with no content. With HTTPS-E disabled it loads successfully.

Chrome 31.0.1650.57 m
HTTPS Everywhere 2013.10.16

comment:8 Changed 6 years ago by pde

Resolution: fixed
Status: closedreopened

Hmmm, that's not good. I can't reproduce that example (it all loads for me), but if you're seeing HTTPS E as a definitel causal variable, I'm going to reopen this bug.

comment:9 Changed 5 years ago by jsha

Resolution: fixed
Status: reopenedclosed

I can't reproduce either. Google Maps has changed a lot lately, so it may be fixed. Realityexists, please reopen if you can still reproduce. I'm on Chromium 36.0.1985.125 Ubuntu 14.04 (283153), HTTPS Everywhere 2014.8.22.

comment:10 Changed 5 years ago by realityexists

OK, it now works for me, too.

Note: See TracTickets for help on using tickets.