Opened 6 years ago

Closed 6 years ago

#9474 closed defect (fixed)

[9gag.com] HTTPS-Everywhere not redirecting GETs made after page load

Reported by: zyan Owned by: zyan
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: #7851 Points:
Reviewer: Sponsor:

Description

Reported via email:

"""

I don't know if it's a compatibility issue with one of my addons or something else, but here's what's happening to me:

I'm trying to load 9GAG and while the main page loads, the subsequent AJAX calls are not.

I believe this is happening because, for some reason, this particular website is trying to load HTTP resources even when browsed over HTTPS. Meaning that when I checked with Firebug, I found out my browser was trying to load

http://platform.twitter.com/widgets.js

along with some others (screenshot: http://img27.imageshack.us/img27/7821/noyp.png)

Any advice? for now my only option is to disable HTTPS-Everywhere, because disabling the rules only doesn't seem to work (and, moreover, I'm disabling too many common APIs for my taste - Google mostly - so it's faster if I disable HTTPS-E)

"""

While loading the page in FF23 with HTTPS Everywhere 3.3.1, I got the following errors:

Timestamp: 08/12/2013 05:11:47 PM
Error: wouldMatch is not defined
Source File: chrome://https-everywhere/content/code/HTTPSRules.js
Line: 685

Timestamp: 08/12/2013 05:11:48 PM
Error: [Exception... "'Image HTTP->HTTPS redirection to https://d24w6bsrhbeh9d.cloudfront.net/photo/a9dYj2D_460s_v1.jpg' when calling method: [nsIContentPolicy::shouldLoad]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0" data: no]

Child Tickets

Change History (6)

comment:1 Changed 6 years ago by zyan

Status: newneeds_review

comment:2 Changed 6 years ago by zyan

Status: needs_reviewnew

Actually, it seems like the problem is that HTTPS Everywhere is trying to redirect 9gag.com AJAX calls to HTTPS when they should be moot. This may be related to https://trac.torproject.org/projects/tor/ticket/4286.

comment:3 Changed 6 years ago by zyan

FF output for the AJAX request to auto-load the next page when scrolling:


Got http-on-modify-request: http://9gag.com/?id=aM19jnW&c=10
No window associated with request: http://9gag.com/?id=aM19jnW&c=10
No applicable list rewriting http://9gag.com/?id=aM19jnW&c=10
Processing http://9gag.com/?id=aM19jnW&c=10
Potentially applicable rules for 9gag.com:

9gag

Redirection limit is 20
Found nsIHttpChannel.redirectTo. Using it.
Got onChannelRedirect.
No window associated with request: http://9gag.com/?id=aM19jnW&c=10
No window associated with request: https://9gag.com/?id=aM19jnW&c=10
No applicable list rewriting https://9gag.com/?id=aM19jnW&c=10
Processing https://9gag.com/?id=aM19jnW&c=10
Potentially applicable rules for 9gag.com:

9gag


This seems similar to https://trac.torproject.org/projects/tor/ticket/7503.

comment:4 in reply to:  3 Changed 6 years ago by zyan

Replying to zyan:

FF output for the AJAX request to auto-load the next page when scrolling:

Got http-on-modify-request: http://9gag.com/?id=aM19jnW&c=10
No window associated with request: http://9gag.com/?id=aM19jnW&c=10
No applicable list rewriting http://9gag.com/?id=aM19jnW&c=10
Processing http://9gag.com/?id=aM19jnW&c=10
Potentially applicable rules for 9gag.com:
9gag
Redirection limit is 20
Found nsIHttpChannel.redirectTo. Using it.
Got onChannelRedirect.
No window associated with request: http://9gag.com/?id=aM19jnW&c=10
No window associated with request: https://9gag.com/?id=aM19jnW&c=10
No applicable list rewriting https://9gag.com/?id=aM19jnW&c=10
Processing https://9gag.com/?id=aM19jnW&c=10
Potentially applicable rules for 9gag.com:
9gag

This seems similar to https://trac.torproject.org/projects/tor/ticket/7503.

oops, sorry for the formatting typo above.

comment:5 Changed 6 years ago by zyan

Parent ID: #7851

comment:6 Changed 6 years ago by zyan

Resolution: fixed
Status: newclosed

Closing since the rule is disabled until the parent gets fixed.

Note: See TracTickets for help on using tickets.