Opened 6 years ago

Closed 6 years ago

#9492 closed defect (fixed)

Torbutton logo not updated properly on OSX with TBB 3.0a3

Reported by: mikeperry Owned by: mikeperry
Priority: High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: tbb-3.0, MikePerry201308
Cc: g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

For some reason on OSX, the Torbutton logo isn't being updated to the normal green color in the OSX builds. I don't see any exceptions that caused this, but it's not a good sign. It likely means some of the startup code didn't run properly. As far as I can tell, everything is set correctly for Tor usage, though...

Child Tickets

Attachments (1)

0001-replaced-JavaScript-style-comments-beginning-with-a-.patch (1.6 KB) - added by gk 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by gk

Cc: g.koppen@… added

comment:2 Changed 6 years ago by gk

Status: newneeds_review

But you should see some CSS warning/message. The problem is that I was still in JS mode when making the comments in torbutton.css for fixing #8478. It seems Mac OS X (and Windows!) are offended by this. The attached patch should fix that.
Note: Not getting the Torbutton logo updated does result in not properly faked screen values in this case. Thus, this is (was) indeed a bad sign...

comment:3 Changed 6 years ago by gk

I am wondering how this could have happened at all as the screen values where properly faked when I developed the patch for #8478 and there were no logo issues either. Weird... and maybe a thing a future QA engineer has to worry about ;)

comment:4 Changed 6 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

Thanks for this, gk! Merged in Torbutton's origin/master.

Note: See TracTickets for help on using tickets.