Opened 6 years ago

Closed 3 years ago

#9511 closed defect (fixed)

Status bar icon unnecessarily large

Reported by: EvilHom3r Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords:
Cc: nullishzero@…, rohieb@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

As of HTTPS Everywhere 3.3.2, the icon in the Firefox status bar is made unnecessarily large by the number indicating how many sites were matched. This makes the entire status bar larger than normal. It would be very nice if there was a way to either disable the number, or have some other indicator (such as graying out the icon when no rules as active, as Stylish does).

Child Tickets

TicketStatusOwnerSummaryComponent
#9506closedpdeSize problem with HTTPS Everywhere toolbar button icon when used w/ FirefoxHTTPS Everywhere/EFF-HTTPS Everywhere
#9535closedpdeoption to disable counter in navigation bar iconHTTPS Everywhere/EFF-HTTPS Everywhere

Attachments (1)

2013-08-17_09-40-45vs.png (294.5 KB) - added by EvilHom3r 6 years ago.
3.3.1 vs 3.3.2

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by EvilHom3r

Attachment: 2013-08-17_09-40-45vs.png added

3.3.1 vs 3.3.2

comment:1 Changed 6 years ago by bastik

Is this a duplicate of #9506?

comment:2 Changed 6 years ago by zyan

Hi, that would be due to these changes that we just pulled from master to stable to make the icon show the number of applied rules: https://trac.torproject.org/projects/tor/attachment/ticket/9506/css.diff

Unfortunately graying out the icon won't work because we also pulled in a change to make the icon gray when HTTPS Everywhere is disabled.

This seems like it's bothersome enough to people that we should fix it. I will ping nullishzero about this via email since I can't add people to the cc.

comment:3 Changed 6 years ago by nullishzero

Let me see what I can do; I have somewhat of an idea what may be causing this.

My solution right now will be to fix the size of the icon so that it respects the user's toolbar settings. Eventually, I want to add a feature that would allow the user to disable the ruleset counter.

comment:4 Changed 6 years ago by nullishzero

Cc: nullishzero@… added

comment:5 Changed 6 years ago by rohieb

Cc: rohieb@… added

comment:6 Changed 6 years ago by nullishzero

Please pull and merge https://github.com/nullishzero/https-everywhere to master

I have tested the fix on a few setups, but I strongly recommend not pushing this to stable until a bit more testing is done.

comment:7 Changed 6 years ago by zyan

Status: newneeds_review

nullishzero's fix got rid of the unnecessary icon padding on my setup (FF23, Ubuntu 12.04).

comment:8 Changed 6 years ago by nullishzero

Fix has been merged into upstream master.

comment:9 Changed 6 years ago by baptx

This problem is still here on addons.mozilla.org. It happens with other Firefox addons on Linux, like ModifyHeaders http://stackoverflow.com/questions/11085234/toolbar-icon-height-issue-with-firefox-on-linux. I fixed MofifyHeaders bug myself and tried to fix HTTPSEverywhere but without luck. Please share the code modifications and update to a new version.

comment:10 Changed 5 years ago by baptx

Problem fixed with version 3.4.5. Don't know what part of the code was wrong btw.

comment:11 Changed 3 years ago by cypherpunks

Resolution: fixed
Severity: Normal
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.