Opened 6 years ago

Closed 6 years ago

#9524 closed defect (worksforme)

HTTPS Everywhere 3.4.1 with Ghostery freezes Firefox 22 & 23.0.1 at start.

Reported by: cypherpunks Owned by: micahlee
Priority: Very High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: startup freeze
Cc: micahlee, schoen Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I've just updated to the latest version of HTTPS Everywhere (3.4.1). It immediatley froze FF during starup. I have a lot of other addons so I started disabling the ones that updated recently in safe mode. The first one I disabled was the latest HTTPS Everywhere. Immediately, Firefox could start again in normal mode. No other addons cause that. Previous version also worked just fine. This bug exists in both Firefox 22 and 23.0.1.
I'm using it under Windows 7.
Task Manager shows that memory consumption jumps between higer and lower level and that the browser consumes around 25 to 32% during this, and nothing much happens.

Child Tickets

Change History (10)

comment:1 Changed 6 years ago by pde

Cc: micahlee schoen added

I hope this isn't a second horribly buggy release in two days. I'm disabling autoupdates while we figure out what's going on here.

comment:2 Changed 6 years ago by pde

cypherpunks, do you know which version you were running previously?

comment:3 Changed 6 years ago by pde

There were no changes between 3.3.2 and 3.4.1 that seem likely to cause this.

I suspect this is probably related to all the files that yan copied from master to stable, in which case this bug would also exist in 3.3.2. But I'm not sure.

The disablement of auto updates hasn't propagated yet, and won't until I figure out how to clear our recently-changed web caches :/

comment:4 Changed 6 years ago by cypherpunks

Unfortunately, no. I was just installing updates as they arrived and nothing ever bothered me.

comment:5 in reply to:  4 Changed 6 years ago by cypherpunks

I was having another unfortunate hanging what seemed totally unwarranted so I decided to turn off another extension that was updated at the same time (Ghostery). It did stop hanging of the browser. And hanging was not a one-off event, it repeated before I disabled Ghostery. Then, I re-enabled HTTPS Evverywhere and it worked. It seemed there might have been a conflict with them running simultaneously. I re-enabled Ghostery then (with HTTPS Evverywhere still enabled) and restarted. This time, not only it started but it's still working.
I totally don't get it.

And I have plenty of RAM.

comment:6 Changed 6 years ago by cypherpunks

I think it's a poor memory management on Mozilla's side now. I couldn't even file a bug report there until I switched to safe mode. I can't recall anything like this happening before.

comment:7 Changed 6 years ago by cypherpunks

I just found out I can't be using both HTTPS Everywhere and Ghostery.
E.g., when I try open Wikipedia (just anything), it hangs Firefox. If I disable either HTTPS Everywhere or Ghostery, it works as usual.
Again, they both got updated at the same time and something like this never happened before.

comment:8 Changed 6 years ago by zyan

Priority: blockercritical
Summary: HTTPS Everywhere 3.4.1 freezes Firefox 22 & 23.0.1 at start.HTTPS Everywhere 3.4.1 with Ghostery freezes Firefox 22 & 23.0.1 at start.

comment:9 Changed 6 years ago by micahlee

Owner: changed from pde to micahlee
Status: newassigned

I haven't been able to reproduce this. I downloaded FF22, created a new profile for it, installed Ghostery and restarted, and installed HTTPS Everywhere 3.4.1 and restarted, and visited a bunch of websites that both HTTPS Everywhere and Ghostery affect (like http://boingboing.net/), and it all seems to be working fine.

Bug submitter, do you now think this is a Firefox memory issue rather than an HTTPS Everywhere issue now? Any more information on how to reproduce it?

comment:10 Changed 6 years ago by micahlee

Resolution: worksforme
Status: assignedclosed

I don't think this is an HTTPS Everywhere problem, and can't reproduce it.

Note: See TracTickets for help on using tickets.