Opened 6 years ago

Closed 6 years ago

#9528 closed defect (fixed)

Craigslist breakage

Reported by: cypherpunks Owned by: zyan
Priority: High Milestone: HTTPS-E 3.3
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.4.1
Severity: Keywords: craigslist httpseverywhere
Cc: spammer@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Trying to load images on Craigslist (specifically, the Boston 'Musical Instruments' or other for-sale sections) results in the text loading but any image references to 'images.craigslist.org' (which tend to be over http for some reason) will never load, causing the page to sit in an indefinitely loading state. This is on Ubuntu Linux 11.04 with Firefox 23.0, and was duplicated on Mac OS X 10.8.4 and Firefox 23.0 as well.

https-everywhere plugin version is 3.3.2 (can't seem to find that in the dropdown-lists, unfortunately)

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by cypherpunks

Additional info:

craigslist.org accepts https connections,
images.craigslist.org does not.

comment:2 Changed 6 years ago by zyan

Owner: changed from pde to zyan
Status: newassigned

This has been replicated. It's due to a new Craigslist rule that we merged in that rewrites all *.craigslist.org domains to https, which apparently doesn't work for images.

I contacted Craigslist to ask if they could list any other subdomains that didn't support SSL. Otherwise I think we should disable the rule by default in stable until it gets tested some more.

comment:3 Changed 6 years ago by micahlee

I haven't been able to reproduce this problem. I've tried Firefox 24 beta3 and Iceweasel 17 (my normal browser) with both HTTPS Everywhere 3.3.2, 3.4.1, and 4.0development10.

Craigslist images seem to load fine for me, including musical instruments in Boston:

https://boston.craigslist.org/sob/msg/4012538433.html
https://boston.craigslist.org/nos/msg/4012523113.html

comment:4 Changed 6 years ago by micahlee

Looking at the mailing list, Brian Carpenter reported the bug saying that https://images.craigslist.org wasn't responding to port 443:

https://mail2.eff.org/pipermail/https-everywhere-rules/2013-August/001687.html

But I'm pretty sure Craigslist has since fixed that problem, and now HTTPS Everywhere works fine with it:

https://images.craigslist.org/01414_MbQIVDlHfO_600x450.jpg

comment:5 Changed 6 years ago by zyan

Resolution: fixed
Status: assignedclosed

Chris Mooney at Craiglist confirmed that they now support SSL for images. Hooray!

Note: See TracTickets for help on using tickets.