Opened 11 years ago

Closed 7 years ago

Last modified 7 years ago

#953 closed defect (fixed)

fail: Unmask Screen - Iframe JavaScript

Reported by: keb Owned by:
Priority: Medium Milestone:
Component: Applications/Torbutton Version: Torbutton: 1.2.1
Severity: Keywords:
Cc: keb Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by mikeperry)

torbutton seems to pass all the tests at
http://pseudo-flaw.net/content/tor/torbutton/
except this one:
http://pseudo-flaw.net/tor/torbutton/unmask-screen-iframe-javascript.html

my results:
original XPCNativeWrapper function retrieved
Original Values: Actual Values:
availHeight 550 availHeight 900
availLeft 0 availLeft 0
availTop 0 availTop 0
availWidth 1000 availWidth 1440
colorDepth 24 colorDepth 24
height 550 height 900
left 0 left 0
pixelDepth 24 pixelDepth 24
top 0 top 0
width 1000 width 1440

comments from irc:
[18:34] <mikeperry> that screen thing is a regression
[18:34] <mikeperry> I wonder if its due to an FF3 change

i have firefox 3.0.7 on ubuntu
and i did not test this on earlier firefoxes.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Attachments (1)

torbutton-test-20101011.txt (4.2 KB) - added by keb 9 years ago.
bug still valid with torbutton 1.2.5 and firefox 3.6.10

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by keb

still happening with firefox 3.0.8

comment:2 Changed 10 years ago by keb

still happening with firefox 3.5.2

comment:3 Changed 10 years ago by keb

and with torbutton 1.2.2

comment:4 Changed 9 years ago by mikeperry

Description: modified (diff)
Priority: minornormal

comment:5 Changed 9 years ago by mikeperry

Other mechanisms of unmasking cause us to fail here too. Closed #1057, #1058 as dups of this.

comment:6 Changed 9 years ago by erinn

Version: 1.2.1Torbutton: 1.2.1

Updating the version from 1.2.1 to Torbutton: 1.2.1 so I can close #1743.

Changed 9 years ago by keb

Attachment: torbutton-test-20101011.txt added

bug still valid with torbutton 1.2.5 and firefox 3.6.10

comment:7 Changed 9 years ago by keb

comment:8 Changed 7 years ago by keb

Resolution: Nonefixed
Status: newclosed

Fixed in tor-browser-gnu-linux-x86_64-2.3.25-2-dev-en-US which is torbutton 1.4.6.3 (possibly earlier, didnt test for awhile)

comment:9 Changed 7 years ago by keb

forgot to add: retested the entire set too.

Note: See TracTickets for help on using tickets.