Opened 7 years ago

Closed 7 years ago

#9552 closed defect (fixed)

HTTPS Everywhere reddit video embeds don't work

Reported by: Casper Owned by: pde
Priority: Low Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.4.1
Severity: Keywords: reddit videos embed youtube
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Reddit embedded videos use an insecure URL (eg
http://www.redditmedia.com/mediaembed/1k4mh8) which Firefox 23 blocks by default on the secure https://pay.reddit.com preventing videos from displaying. I looked at the XML source and noticed it refers to Amazon AWS buckets so I tried to look for one for redditmedia.com but without success. Does one exist? Is there a possible workaround to force https youtube so the videos display?

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by zyan

Resolution: worksforme
Status: newclosed

Hi Casper, are you using the Reddit_via_pay.xml rule that redirects http://www.reddit.com to https://pay.reddit.com? It should be off by default.

The main Reddit.xml rule should also show up as off when FF mixed content blocking is enabled.

comment:2 Changed 7 years ago by Casper

Priority: normalminor
Resolution: worksforme
Status: closedreopened

Yes, I'm using the 'reddit (via pay.reddit.com) not officially supported' rule which works well for me except for video embeds due to the insecure redditmedia.com. I've had to disable mixed content blocking to get embeds working. I just thought I would report this in case anyone knows a secure alternative to redditmedia.com for video embeds.

comment:3 Changed 7 years ago by Casper

Resolution: fixed
Status: reopenedclosed

redditmedia.com now supports https so the issue is resolved.

Note: See TracTickets for help on using tickets.