Opened 7 years ago

Closed 6 years ago

#9656 closed defect (fixed)

Barnes & Noble ruleset triggers MCB

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.4.1
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Using Firefox 23.0.1 with HTTPS Everywhere 3.3.1, the Barnes & Noble website does not work properly. Specifically, visiting the home page at http://www.barnesandnoble.com/ works fine, but visiting pages like http://www.barnesandnoble.com/u/books-bestselling-books/379003057/ fail, in part at least because images pulled from imagesbn.com no longer load. Disabling HTTPS Everywhere fixes the problem. Alternatively, disabling the "Barnes and Noble (partial)" ruleset also fixes the problem.

BTW, I have incorrectly flagged this report as applying to HTTPS Everywhere 3.4.1 because this bug reporting system doesn't seem to even know about the current 3.3.1 release.

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by cypherpunks

It also breaks the functionality on some book pages.

TO REPRODUCE

1) Load this page: http://www.barnesandnoble.com/w/2012-13-paris-restaurants-zagat-survey/1116806804?ean=9781604784459

2) Next to "Other sellers" click "Used" (or any other option)

3) Expected behavior: Displays list of used copies for sale

Actual behavior: (Nothing happens)

4) Disable HTTPS-Everywhere rule for "Barnes and Noble (partail)" and reload page

5) Repeat step 2

6) Expected and actual behavior: Displays list of used copies for sale

SYSTEM

  • HTTPS-Everywhere 3.4.1
  • HTTPS Finder 0.85 (in case that matters)
  • Firefox ESR 17.0.8 (with many add-ons)
  • Win7 x64

comment:2 Changed 6 years ago by bm

Resolution: fixed
Status: newclosed
Summary: Barnes & Noble ruleset is brokenBarnes & Noble ruleset triggers MCB

The rule was disabled sometime before 9dcd474d for 4.0 and marked as mixedcontent in 8b167bdf for 5.0.

Note: See TracTickets for help on using tickets.