Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#9696 closed defect (worksforme)

New Identity doesn't clear download UI history

Reported by: mikeperry Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, tbb-newnym, tbb-torbutton
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We should clear it. There's a 'Clear' button in the UI that probably makes an XPCOM call that does it.

The actual download manager storage is memory-only, so this isn't a disk leak issue, but it is a usability one.

Child Tickets

Change History (10)

comment:1 Changed 6 years ago by gk

I just stumbled over the Mozilla way to erase downloads if the user wishes so:
https://mxr.mozilla.org/mozilla-central/source/browser/base/content/sanitize.js#310

comment:2 Changed 6 years ago by arma

Keywords: tbb-newnym added

comment:3 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:4 Changed 4 years ago by bugzilla

Keywords: tbb-privacy-local removed
Resolution: fixed
Severity: Normal
Status: newclosed

comment:5 Changed 4 years ago by cypherpunks

Resolution: fixed
Status: closedreopened

@bugzilla - What's the point of closing everything without giving a source or reference to back it up?

Version 0, edited 4 years ago by cypherpunks (next)

comment:6 Changed 4 years ago by bugzilla

The ticket is opened during 2 years without any progress. Every search finds it as still unfixed. So, at a first glance, it looks like "New Identity doesn't clear (something)" - What? Leakage? Not fixed for 2 years???
But in reality bug is so minor that Mike, probably, fixed it and forgot to close the ticket.
So, have you reproduced that to reopen the ticket?

comment:7 in reply to:  6 ; Changed 4 years ago by gk

Resolution: worksforme
Status: reopenedclosed

Replying to bugzilla:

The ticket is opened during 2 years without any progress. Every search finds it as still unfixed. So, at a first glance, it looks like "New Identity doesn't clear (something)" - What? Leakage? Not fixed for 2 years???
But in reality bug is so minor that Mike, probably, fixed it and forgot to close the ticket.

Still, please, don't close tickets just because they are minor and got probably fixed meanwhile.

So, have you reproduced that to reopen the ticket?

Actually, the issue seems indeed to be fixed. If not, please reopen with steps to reproduce.

comment:8 in reply to:  7 ; Changed 4 years ago by bugzilla

Replying to gk:

Still, please, don't close tickets just because they are minor and got probably fixed meanwhile.

Severity has never been the reason of closing. "probably" is not enough for closing too. If there is no movement in a ticket for years then it means nobody has this issue or the project is dead. Nevertheless, it's better to close the ticket (for users and for devs), and you proved that.
Fixed ticket must be marked as fixed, but you offer to make it by posting a comment instead of using built-in functionality of Trac. Strangely...
Closing the ticket as "worksforme" shows that the problem wasn't investigated thoroughly, and makes some users concerned about it. But Mike wrote that the resolution consisted of one XPCOM call. It works for everyone, not for you only.

comment:9 in reply to:  8 ; Changed 4 years ago by gk

Replying to bugzilla:

Replying to gk:

Still, please, don't close tickets just because they are minor and got probably fixed meanwhile.

Severity has never been the reason of closing. "probably" is not enough for closing too. If there is no movement in a ticket for years then it means nobody has this issue or the project is dead.

Not necessarily.

Nevertheless, it's better to close the ticket (for users and for devs), and you proved that.

If one has tested that this issue is not an issue anymore, yes, sure.

Fixed ticket must be marked as fixed, but you offer to make it by posting a comment instead of using built-in functionality of Trac. Strangely...

Well, I tested the latest Tor Browser on different platforms and it works for me. That's all I can say. Whether we fixed it or anybody else (e.g. Mozilla) I don't know. If you think that's worthwhile to investigate feel free to do it. I'd be interested to know why this is working now.

comment:10 in reply to:  9 Changed 4 years ago by bugzilla

Replying to gk:

If there is no movement in a ticket for years then it means nobody has this issue or the project is dead.

Not necessarily.

Of course, that's not all the reasons, but situation is far from good.

I'd be interested to know why this is working now.

Search through the git repo revealed that there was only one record in the log, related to about:downloads within 2 years:
https://gitweb.torproject.org/tor-browser.git/commit/?h=tor-browser-38.6.0esr-5.5-1&id=4a6c504a9e667144339dd4d5b3ea3c077a3e2a38
So, probably, this bugfix allowed about:downloads to obey general 'Clear All History' call.
Propose closing as FIXED.

Note: See TracTickets for help on using tickets.