Opened 7 years ago

Closed 7 years ago

#9758 closed defect (not a bug)

AccountingMax == writes in 0.2.4.x?

Reported by: tmpname0901 Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.16-rc
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

My understanding is that what the AccountingMax setting matches against is traffic written. This seems reasonable for v0.2.3.x given that it writes slightly more than it reads.

My experience with v0.2.4.17 on multiple relays, though, is that more bytes are read than written, e.g.:

AccountingBytesReadInInterval 4523345070080
AccountingBytesWrittenInInterval 4398491181056

If AccountingMax is still compared to bytes written then we risk exceeding the user-specified maximum traffic per accounting period.

(Possibly these stats are influenced by the recent botnet activity.)

Note: I am setting the version number for this ticket as 0.2.4.16-rc because 0.2.4.17-rc is not available in the Version drop-down menu.

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by nickm

Resolution: not a bug
Status: newclosed

The accountingmax applies to *both* bytes written and bytes read, so I believe there isn't a problem here. Example code:

  return n_bytes_read_in_interval >= hard_limit
    || n_bytes_written_in_interval >= hard_limit;

(Adding 0.2.4.17-rc to the list of versions)

Note: See TracTickets for help on using tickets.