Opened 6 years ago

Closed 3 years ago

#9773 closed defect (worksforme)

[warn] tor_timegm(): Bug: Out-of-range argument to tor_timegm

Reported by: arma Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-auth, tor-03-unspecified-201612
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

moria1, running Tor 0.2.5.0-alpha-dev (git-8f0755fa85b9c1fb), once saw

Jul 25 02:55:01.546 [warn] tor_timegm(): Bug: Out-of-range argument to tor_timegm

No other hints, at info-level, around it. I assume maybe it came in a descriptor of some sort, or a netinfo or something.

Bug #6811 looks like the last time we touched this stuff, but it was a while ago.

Should this turn into a log-protocol-warn when it's based on network input? In any case, it's not a Bug:, right? Unless we think there's a code path where it is?

Child Tickets

Change History (6)

comment:1 Changed 6 years ago by nickm

I think it is a bug, and it's one that will become easy to solve once my backtrace-on-bug code is in. :)

comment:2 Changed 6 years ago by nickm

Milestone: Tor: 0.2.5.x-finalTor: 0.2.???

comment:3 Changed 5 years ago by nickm

Status: newneeds_information

comment:4 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:5 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:6 Changed 3 years ago by nickm

Resolution: worksforme
Severity: Normal
Status: needs_informationclosed

Closing as likely fixed, given that I haven't seen it coming up again with the legit code. (Or is this a duplicate of something we fixed?)

Note: See TracTickets for help on using tickets.