Opened 6 years ago

Closed 6 years ago

#9782 closed defect (fixed)

Tor crashes when setting relay

Reported by: Alchemist Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.4.17-rc
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

OS: Linux Mint 13 - all updates - both the 64 and 32-bit editions.

Tor in TBB 2.3.25.12-dev-en-US and 2.4.17-beta-1-dev-en.US crashes when setting relay. It happens whether or not contact info is set, and regardless of bandwith or exit/no exit settings. The following messages are generated:

Unexpected Error
Vidalia detected that the Tor software exited unexpectedly.
Please check the message log for recent warning or error messages

Error Applying Settings
Vidalia was unable to apply your Server settings to Tor.
Control socket is not connected.

Here is the log output:

Sep 19 11:33:25.143 [Notice] Tor v0.2.3.25 (git-17c24b3118224d65) running on Linux.
Sep 19 11:33:25.143 [Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Sep 19 11:33:25.143 [Notice] Read configuration file "/home/al/Downloads/tor-browser_en-US-2.3.25.12-dev-en-US/App/../Data/Tor/torrc".
Sep 19 11:33:25.143 [Notice] Initialized libevent version 2.0.21-stable using method epoll (with changelist). Good.
Sep 19 11:33:25.143 [Notice] Opening Socks listener on 127.0.0.1:9150
Sep 19 11:33:25.143 [Notice] Opening Control listener on 127.0.0.1:9151
Sep 19 11:33:25.143 [Notice] Parsing GEOIP file ./Data/Tor/geoip.
Sep 19 11:33:25.816 [Notice] No AES engine found; using AES_* functions.
Sep 19 11:33:25.816 [Notice] This OpenSSL has a good implementation of counter mode; using it.
Sep 19 11:33:25.816 [Notice] OpenSSL OpenSSL 1.0.0k 5 Feb 2013 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Sep 19 11:33:25.816 [Notice] Reloaded microdescriptor cache. Found 4150 descriptors.
Sep 19 11:33:25.816 [Notice] We now have enough directory information to build circuits.
Sep 19 11:33:25.816 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Sep 19 11:33:25.816 [Notice] New control connection opened.
Sep 19 11:33:26.605 [Notice] Heartbeat: Tor's uptime is 0:00 hours, with 4 circuits open. I've sent 0 kB and received 0 kB.
Sep 19 11:33:26.718 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Sep 19 11:33:27.137 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Sep 19 11:33:28.806 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Sep 19 11:33:28.806 [Notice] Bootstrapped 100%: Done.
Sep 19 11:34:09.068 [Notice] Your ContactInfo config option is not set. Please consider setting it, so we can contact you if your server is misconfigured or something else goes wrong.
Sep 19 11:34:09.069 [Notice] Opening Directory listener on 0.0.0.0:9030
Sep 19 11:34:09.069 [Notice] Opening OR listener on 0.0.0.0:9001
Sep 19 11:34:09.069 [Notice] Your Tor server's identity key fingerprint is 'Unnamed C5CE8FB839424BA458834E6EEB52D739046A4C1D'
Sep 19 11:34:09.071 [Notice] Now checking whether ORPort 99.29.28.231:9001 and DirPort 99.29.28.231:9030 are reachable... (this may take up to 20 minutes -- look for log messages indicating success)
Sep 19 11:34:09.071 [Warning] Unable to stat resolver configuration in '/etc/resolv.conf': No such file or directory
Sep 19 11:34:09.074 [Error] set_options(): Bug: Acting on config options left us in a broken state. Dying.

Child Tickets

Change History (7)

comment:1 Changed 6 years ago by nickm

Do you in fact have a missing /etc/resolv.conf file?

comment:2 in reply to:  1 Changed 6 years ago by Alchemist

Replying to nickm:

Do you in fact have a missing /etc/resolv.conf file?

(slaps forehead) No, I don't have the file. It is missing. I have a /etc/resolvconf/ folder which contains
/etc/resolvconf/resolv.conf.d/
/etc/resolvconf/update.d/
/etc/resolvconf/update-libc.d/
/etc/resolvconf/interface-order

The TBB versions prior to the ones mentioned in this ticket all worked fine, as clients and as relays. Did they need the /etc/resolv.conf file? I wonder if an OS update removed it.

Should I create a resolv.conf file, and what should it contain?

Last edited 6 years ago by Alchemist (previous) (diff)

comment:3 Changed 6 years ago by Alchemist

It seems that Linux Mint 13 does not use a /etc/resolv.conf file, but instead uses dnsmasq. That still leaves the question, why do the newest TBB work as clients, but crash when setting a relay? The older TBB versions worked under Mint 13 as both clients and relays.

comment:4 Changed 6 years ago by nickm

What were the older versions that worked, exactly? Looking at the source code, it seems that have tried to initialize the dns subsystem when running as a relay for some while now.

Generally, you can make a perfectly fine resolv.conf file by just putting in something like

Nameserver x.y.z.w
Nameserver x.y.z.w

with one Nameserver line for each of your nameservers, filling in the IPv4 address of each nameserver.

You don't need to put it in /etc/resolv.conf, either -- you can override the file location with ServerDNSResolvConfFile

comment:5 Changed 6 years ago by Alchemist

Thanks for your help. I don't know exactly which older versions, I'll download a few and try them. In the meantime I'll just make a resolv.conf file with 8.8.8.8 and 8.8.4.4.

comment:6 Changed 6 years ago by Alchemist

Made an /etc/resolv.conf with 8.8.8.8, 8.8.4.4, 208.67.222.222, and 208.67.220.220 and the relay works. It wasn't a Tor problem but rather an OS peculiarity. I tried a couple of older versions and they also crash with the same resolv.conf error on Mint 13. I have a few Linux boxen with a mix of distros and the problem only occurs with Mint 13 - the other distros have a resolv.conf file. Thanks again for your help, and I apologize for taking up your time. Next time (if there is a next time) I'll try to be more thorough and assure it really is a Tor problem. I suppose this ticket can be closed out.

comment:7 Changed 6 years ago by Alchemist

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.