Opened 6 years ago

Closed 6 years ago

#9803 closed defect (fixed)

uri.host is explosive!

Reported by: grgoffe Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/HTTPS Everywhere: Chrome Version:
Severity: Keywords:
Cc: EisahLee@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I just started getting these messages a few weeks ago and finally found the source of them. Now I'm reporting them and trying to find out why they appear. The appear on the console/xterm/konsole where I start Firefox (current production version) on my Fedora 16 x86_64 system.

I'll leave the priority of this ticket as normal since I don't know how bad things are with this bug, IF this is a bug.

Can you let me know what to do about them please?

Here's a few of the messages:

uri.host is explosive!
(about:blank)
Could not check applicable rules for about:blank
uri.host is explosive!
(about:blank)
Could not check applicable rules for about:blank
uri.host is explosive!
(about:blank)
Could not check applicable rules for about:blank
uri.host is explosive!
(about:blank)
Could not check applicable rules for about:blank
uri.host is explosive!
(about:addons)
Could not check applicable rules for about:addons
uri.host is explosive!
(about:addons)
Could not check applicable rules for about:addons
uri.host is explosive!
(about:blank)
Could not check applicable rules for about:blank

Child Tickets

Attachments (1)

0001-Fix-uri.host-is-explosive-messages.patch (1.7 KB) - added by eisahlee 6 years ago.
Suggested fix to suppress error messages on trivial pages

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by grgoffe

I would be willing to work with anyone who wants to test possible fixes for this or whatever other actions might be needed.

THANKS!

George...

comment:2 Changed 6 years ago by eisahlee

I've seen this for quite a while now, and I'm getting really annoyed by the log-spam. Even if I wouldn't start it from the console, these superfluous messages could hide "important" ones.

It seems that the current behavior is caused by the fix for https://trac.torproject.org/projects/tor/ticket/6388

I'm not any good with javascript, but I hope that this should handle the trivial cases, where HTTPSEverywhere really should just keep quiet, e.g. about:newtab, about:blank, about:addons, etc. This is why I chose the most naive approach: Check whether the uri.spec starts with "about:".

I have no experience with javascript. I couldn't even test this "fix". (But at least, it is in a common format, thanks to git format-patch.)

George, and any other dev: If you build a "testing" version (either of this patch, or any other way to fix it; I don't care) and send/link me to it, I can check whether it works.

With regards,
Eisah

comment:3 Changed 6 years ago by eisahlee

Cc: EisahLee@… added

Changed 6 years ago by eisahlee

Suggested fix to suppress error messages on trivial pages

comment:4 Changed 6 years ago by eisahlee

I was finally cured from blindness, and found ./makexpi.sh

I was able to install the resulting pkg/https-everywhere-4.0development.13~pre.xpi (I used the very latest version, not the latest stable one) in a new firefox profile without any problems.

Starting it from a new console (firefox -P test -no-remote), opening a new tabs and generally playing around with it, it seems that the "spammy" behavior is now fixed.

I'm looking forward to your feedback :)

comment:5 Changed 6 years ago by pde

Resolution: fixed
Status: newclosed

Hi eisahlee,

it turns out there are more cases where this doesn't work besides about: (file:, data:, javascript:, ...) so in git I've fixed it by just turning down the verbosity of the log message.

Note: See TracTickets for help on using tickets.