Opened 6 years ago

Last modified 12 months ago

#9835 reopened task

Backup Stack Exchange Tor site

Reported by: lunar Owned by: lunar
Priority: Medium Milestone:
Component: Community/Tor Support Version:
Severity: Normal Keywords:
Cc: runa Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It looks like we are going live with the Tor Stack Exchange Q&A site. There is going to be a lot of valuable thoughts in there, and it is probably a good idea to have our own backups in case Stack Exchange falls, fails or bails on the Tor project.

It should probably be done using a query run regularly against http://data.stackexchange.com/ or maybe using the data dumps http://www.clearbits.net/creators/146-stack-exchange-data-dump

Child Tickets

Change History (16)

comment:1 Changed 6 years ago by arma

Good thinking.

comment:2 Changed 6 years ago by weasel

I agree that somebody should do it. I'm not certain why you think the people taking care of our torproject.org hosts must be the ones doing it.

comment:3 Changed 6 years ago by lunar

I assumed there was already a backup system in place for torproject.org hosts with disk space, rotation and verification procedures. Under that assumption, it made sense to put the data in the same place as other backups to me.

comment:4 Changed 6 years ago by weasel

There is, for hosts. Hacking it up to support other stuff isn't trivial.

comment:5 Changed 6 years ago by lunar

I have to shoot in the dark given I have no clue about the current system. If one of torproject.org host with enough disk space would retrieve information from StackExchange in a regular enough fashion and write them in a directory that is part of the backup set, that should work, right?

comment:6 Changed 6 years ago by weasel

Yes. Maybe somebody can do that on for instance perdulce? Maybe even keep a couple versions. How big can this data be, after all.

comment:7 Changed 5 years ago by weasel

Resolution: not a bug
Status: newclosed

Not a sysadmin task.

comment:8 Changed 5 years ago by lunar

Component: Tor Sysadmin TeamTor Support
Resolution: not a bug
Status: closedreopened

comment:9 Changed 5 years ago by lunar

Owner: set to lunar
Status: reopenedassigned

comment:10 Changed 5 years ago by lunar

perdulce is backed up daily. So let's find a way write the freshest dump everyday in ~lunar/se-backup.

comment:11 Changed 5 years ago by lunar

I was unable to retrieve anything from tor.stackexchange.com from data.SE. I have just sent an email to team@stackoverflow to ask what could be done.

comment:12 Changed 5 years ago by lunar

Answer from the StackExchange team:

We don't put beta sites into the data explorer, because it takes a bit of work to set them up; this is something we do once the site graduates. If we were to close the site for _any_ reason (which is also _extremely_ unlikely), we'd provide you with a full data dump that you could reconstruct all non-deleted content with.
Our own backup policy (everything eventually lands on tape, real time SQL replication between data centers, daily or better DB backups) guarantees that we're not going to lose the content prior to it being included in our periodic data dumps, which also happens once a site has graduated.

Let us know if you have any additional concerns - you don't need to worry about your content, we've got it covered.

Sure, it's covered, but it's not on hard drives we control… :(

comment:13 Changed 3 years ago by isabela

Component: User Experience/Tor SupportCommunity/Tor Support

comment:14 Changed 18 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:15 Changed 12 months ago by cypherpunks

Resolution: invalid
Status: assignedclosed

comment:16 Changed 12 months ago by cypherpunks

Resolution: invalid
Status: closedreopened
Note: See TracTickets for help on using tickets.