Opened 6 years ago

Closed 6 years ago

#9838 closed defect (duplicate)

TBB 3.0-alpha-4 empty network settings window

Reported by: Sherief Owned by: mikeperry
Priority: High Milestone:
Component: Applications/Tor Launcher Version:
Severity: Keywords: tbb-3.0
Cc: arma, g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If I install and run torbrowser-install-3.0-alpha-4_en-US.exe on my Window 7 64-bit box I get back an empty Network Settings window and it stays that way forever and TorBrowser never launches.

Attached a screen shot of the window.

Child Tickets

Attachments (1)

Empty Network Settings Window.png (15.4 KB) - added by Sherief 6 years ago.

Download all attachments as: .zip

Change History (14)

Changed 6 years ago by Sherief

comment:1 Changed 6 years ago by gk

Cc: g.koppen@… added

comment:2 Changed 6 years ago by lance

Tested on 32x windows enterprise did not see anything like this. Do you have anymore info on this experience ?

comment:3 Changed 6 years ago by gk

Do former TBB 3.0 versions work (see: https://archive.torproject.org/tor-package-archive/torbrowser/ for older ones)? If so, which breaks first?

comment:4 in reply to:  3 Changed 6 years ago by Sherief

Replying to gk:

Do former TBB 3.0 versions work (see: https://archive.torproject.org/tor-package-archive/torbrowser/ for older ones)? If so, which breaks first?

3.0a1(Crashes, no window)
3.0a2/3/4 (See attachment.)

If there is any thing you would like me to test please email me at sheriefalaa dot w at gmail or just comment here.

comment:5 Changed 6 years ago by gk

Does your problem go away if you use a non-en-US bundle?

comment:6 in reply to:  5 Changed 6 years ago by Sherief

Replying to gk:

Does your problem go away if you use a non-en-US bundle?

I just tested with torbrowser-install-3.0-alpha-4_fa.exe I got the same result, an empty window (window title in Farsi).

comment:7 Changed 6 years ago by arma

See #9438 which appears to be the same thing -- still unfixed.

(Thanks, anonymous person on the blog!)

comment:8 Changed 6 years ago by arma

Keywords: tbb-3.0 added

comment:9 Changed 6 years ago by gk

Sherief, could you test whether:

The fix you need to apply before running TBB 3.0 on Windows is:

Add this line to your prefs.js file when TorBrowser is not running. Prefs.js is created only after the first run of TorBrowser.

Tor Browser > FirefoxPortable > Data > profile > "prefs.js"

user_pref("gfx.direct2d.disabled", true);
user_pref("layers.acceleration.disabled", true);

fixes your problem?

comment:10 Changed 6 years ago by mikeperry

If this is specific to non-English languages this smells more like #9144.

Does anyone experience this with English?

Do the prefs actually help? One of them is already set.

comment:11 in reply to:  10 Changed 6 years ago by gk

Replying to mikeperry:

If this is specific to non-English languages this smells more like #9144.

Does anyone experience this with English?

I assumed Sherief has been trying the en-US bundle as well (quoting from the bug description):

If I install and run torbrowser-install-3.0-alpha-4_en-US.exe on my Window 7 64-bit box

:)

comment:12 in reply to:  9 Changed 6 years ago by Sherief

Replying to gk:

Sherief, could you test whether:

The fix you need to apply before running TBB 3.0 on Windows is:

Add this line to your prefs.js file when TorBrowser is not running. Prefs.js is created only after the first run of TorBrowser.

Tor Browser > FirefoxPortable > Data > profile > "prefs.js"

user_pref("gfx.direct2d.disabled", true);
user_pref("layers.acceleration.disabled", true);

fixes your problem?

Yes! it did fix the problem.

comment:13 Changed 6 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #9438.

Note: See TracTickets for help on using tickets.