Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9842 closed defect (invalid)

dnsport listener using tcp and not udp

Reported by: phin Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.17-rc
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor version 0.2.4.17-rc (git-00fb525b23cf070f)

built from sources : https://www.torproject.org/dist/tor-0.2.4.17-rc.tar.gz

when adding the 'DNSPort 5353' command to torrc a socket listener is created on TCP 127.0.0.1:5353 and not UDP as has been the previous versions behavior.

Child Tickets

Change History (6)

comment:1 Changed 6 years ago by phin

Additionally tested on a ubuntu box using the quantal experimental repo and the listener is using UDP now as expected.

Tor version 0.2.4.17-rc (git-36eb3e0da4c3a821)

So I assume the sources on the site just need to be updated with the next RC.

comment:2 Changed 6 years ago by arma

Component: - Select a componentTor
Keywords: tor-relay added

How odd. I don't see how the deb would be different from whatever you built from source. Unless you are running the one you built from source wrong, or built it wrong, or something?

comment:3 in reply to:  2 Changed 6 years ago by phin

Replying to arma:

How odd. I don't see how the deb would be different from whatever you built from source. Unless you are running the one you built from source wrong, or built it wrong, or something?

Tested again using a fresh install of arch and same result, DNS listener on TCP port 5353 and not UDP port 5353 when using the sources located here:

https://www.torproject.org/dist/tor-0.2.4.17-rc.tar.gz

sha1 ed19e93188d620e1a5bca0e6c243ef5941490c05 tor-0.2.4.17-rc.tar.gz
md5 2cdfb8dcc3306a43cf465a858bf97b2d tor-0.2.4.17-rc.tar.gz

# tor --version
Tor version 0.2.4.17-rc (git-00fb525b23cf070f).

# ss -atunp | grep tor
tcp UNCONN 0 0 127.0.0.1:5353 *:* users:(("tor",424,7))
tcp LISTEN 0 128 127.0.0.1:9050 *:* users:(("tor",424,6))

Did a './configure', and then a 'make', finally a 'make install' to build. Then created a torrc with only 'DNSPort 5353' in it and did 'tor -f torrc'.

So I don't see where I could have built or be running it wrong. The results imply the tarball and .deb are indeed different. As do the git ids but that could be merges, rebases, etc.

I'll test again tomorrow with a fresh gentoo and ubuntu install to make sure it isn't my tool chain but I'm pretty certain it's the tarball. And regardless of the existence of a difference in the tarball and the .deb, the tarball is definitely bug'd since a DNS listener on TCP is not intended behavior by everything I have read.

I guess I could search git commits but the motivation escapes me at the moment. :)

comment:4 Changed 6 years ago by phin

So go figure it works just fine in ubuntu and gentoo.

I went back and pcap'd some and noticed that there was indeed a listener on udp. I installed netstat and it confirms that tor was opening a listener on udp despite what ss was showing. I also confirmed that any udp listener (like netcat -l -u) showed up as tcp in ss. This seems to be an issue with the ss/arch combo so I will close this ticket and continue it with them.

Sorry for the time waste.

Last edited 6 years ago by phin (previous) (diff)

comment:5 Changed 6 years ago by phin

Resolution: invalid
Status: newclosed

comment:6 in reply to:  4 Changed 6 years ago by nickm

Replying to phin:

Sorry for the time waste.

Don't worry about it: I'd rather get some false alarms from time to time than miss a genuinely serious bug.

Note: See TracTickets for help on using tickets.