Opened 7 years ago

Closed 7 years ago

#9858 closed defect (fixed)

unzip breaks bundling TBBs based on Firefox 24 ESR

Reported by: gk Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-3.0, ff24-esr
Cc: mikeperry Actual Points:
Parent ID: #10103 Points:
Reviewer: Sponsor:

Description

While un- and rezipping omni.ja is working fine with Firefox 17 ESR it breaks the last stage in creating the TBBs if Firefox 24 ESR is used due the following error:

+ unzip ../omni.ja defaults/preferences/000-tor-browser.js
Archive:  ../omni.ja
warning [../omni.ja]:  3496165 extra bytes at beginning or within zipfile
  (attempting to process anyway)
error [../omni.ja]:  reported length of central directory is
  -3496165 bytes too long (Atari STZip zipfile?  J.H.Holm ZIPSPLIT 1.1
  zipfile?).  Compensating...
  inflating: defaults/preferences/000-tor-browser.js

Child Tickets

Change History (9)

comment:1 Changed 7 years ago by gk

See: https://bugzilla.mozilla.org/show_bug.cgi?id=605524 for a good summary of the problem.

comment:2 Changed 7 years ago by gk

I have a workaround for this issue and will attach a proper patch for all three bundle descriptors as soon as I am able to test the Linux and Mac ones (which requires at least fixing #9828 and #9829).

comment:3 Changed 7 years ago by gk

Parent ID: #9827#10103

comment:4 Changed 7 years ago by gk

A workaround for this one is

zipsplit -n 200000000 omni.ja
unzip omni1.zip defaults/preferences/000-tor-browser.js
rm omni1.zip

comment:5 Changed 7 years ago by gk

Cc: mikeperry added

The pushd/popd trick does not work on Mac OS X. I still get the same error without using the zipsplit workaround. Not sure what on Windows is happening yet.

Last edited 7 years ago by gk (previous) (diff)

comment:6 Changed 7 years ago by mikeperry

Ok, well I pushed the mac+windows fix from #9828 to the ff24-staging remote of https://git.torproject.org/user/mikeperry/tor-browser-bundle.git. I think it should fix this, too?

comment:7 Changed 7 years ago by gk

As I said above (comment 5) the pushd/popd trick is not working on Mac OS X. I still need to include the zipsplit workaround. Not sure about Windows yet, need to fix #9830 comment 9 first...

comment:8 Changed 7 years ago by gk

11:19 < mikeperry> well I think actually it might have been the re-dzip.sh

addition to the gitian-firefox.yml for linux that fixed it

11:19 < mikeperry> at least thats what I recall fixing it for me
11:20 < GeKo> I don't think so as the first unzip is already breaking things.
11:20 < GeKo> and this is way before calling re-dzip.sh
11:22 < mikeperry> no, in the firefox descriptor. right after the build:
https://gitweb.torproject.org/builders/tor-browser-bundle.git/blob/HEAD:/gitian/descriptors/linux/gitian-firefox.yml#l109
11:22 < GeKo> Aha!

comment:9 Changed 7 years ago by mikeperry

Resolution: fixed
Status: newclosed

I believe this is fixed then. It's at least fixed for me. Reopen otherwise?

Note: See TracTickets for help on using tickets.