Opened 7 years ago

Closed 6 years ago

#9878 closed task (fixed)

Mention the pyptlib version in obfsproxy's starting log

Reported by: asn Owned by: asn
Priority: Medium Milestone:
Component: Archived/Obfsproxy Version:
Severity: Keywords: easy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

obfsproxy currently logs this in startup:

[WARNING] Obfsproxy (version: 0.2.2_9_g37c9cbe-py2.7.egg) starting up.

It would be nice if that log also included the pyptlib version that it's using.

Child Tickets

Attachments (2)

fix-9878-pyptlib.patch (1.1 KB) - added by johngian 6 years ago.
fix-9878-obfsproxy.patch (1.1 KB) - added by johngian 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by asn

Keywords: easy added

Changed 6 years ago by johngian

Attachment: fix-9878-pyptlib.patch added

Changed 6 years ago by johngian

Attachment: fix-9878-obfsproxy.patch added

comment:2 Changed 6 years ago by johngian

Hi!

I tried to solve this issue in the 2 patches attached.

Regarding the obfsproxy patch, I don't really like the try/except in imports, but I wasn't sure how close is the version of obfsproxy to pyptlib. Also I am not sure if it's right to patch pyptlib under that component but it seems to me like a clear approach.

comment:3 Changed 6 years ago by asn

Resolution: fixed
Status: newclosed

Merged and pushed. Thanks!

(Here is a few more tasks if you want to play more:
https://trac.torproject.org/projects/tor/wiki/doc/PluggableTransports#Helpneeded )

Note: See TracTickets for help on using tickets.