Opened 6 years ago

Closed 6 years ago

#9895 closed defect (fixed)

DebugInfo files are not copied to the OUTPUT directory

Reported by: gk Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-3.0
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While #9487 handles the creation of DebugInfo files, they are still missing in the OUTPUT directory creating a

cp: cannot stat 'build/out*debug.zip': No such file or directory

error.

Child Tickets

Attachments (1)

0001-Bug-9895-Copying-the-DebugInfo-Files-to-OUTPUT-remov.patch (1.5 KB) - added by gk 6 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by gk

Status: newneeds_review

comment:2 Changed 6 years ago by gk

The interesting thing to note here is that this bug breaks the Vagrant/LXC build while KVM is not really bothering. I am wondering whether that fact (that KVM is not failing hard) should be treated as a bug itself.

comment:3 Changed 6 years ago by gk

Keywords: tbb-3.0 added; tbb3.0 removed

comment:4 Changed 6 years ago by gk

5b8f373e5fdfc733d2c4c1713337fd0112181db5 is probably fixing this issue if I understand it correctly and with a much better patch, nice. So, the 'needs_review ' is then actually only for the change to the Makefile now.

comment:5 Changed 6 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

Added the debuginfo clean rule.

Note: See TracTickets for help on using tickets.