Opened 3 years ago

Closed 2 years ago

#9906 closed defect (fixed)

TBB new identity surprises users by closing all tabs

Reported by: torland Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-3.0, tbb-newnym, tbb-usability, extdev-interview, tbb-helpdesk-frequent, tbb-torbutton, TorBrowserTeam201502, MikePerry201502
Cc: gk, isis, mcs, gigel Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I click the TorButton in TBB-3.0a4 and select "New Identity", the complete torbrowser is restarted. This is a secure but not very user friendly behavior because all pages I am viewing at the moment are gone. My usual browser session consists of 20-30 open tabs that loose. Selecting a new identity is important from time to time if the current circuit hangs or i.e. google does block the current exit node.

Child Tickets

Attachments (1)

TICKET-9906-user-feedback-from-twitter.jpg (248.4 KB) - added by isis 3 years ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 3 years ago by torland

  • Keywords tbb-3.0 added

comment:2 follow-up: Changed 3 years ago by joebt

Not sure what you mean by "restarted," but in 3.0a4 on Vista x64, clicking New Identity closes open tabs & leaves the "about Tor" tab /page open. But the browser doesn't close, then restart.

I agree - an irritating "bug." If this is by design, have to figure a way to save open tabs, if ever want to use New Identity.

EDIT 10/12/2013: Discovered something else. In older TBB 2.3.25-12/13, if use the green onion in NAV BAR for New Identity, it closes the browser & restarts it, as torland said.

If I use the onion in ADDON bar (assuming icon is there), & click New Identity, it does NOT restart the browser. It shows a pop up w/ message, to effect: "A new identity will be used on all NEW connections." 

Watching the network map while clicking New Identity in Addon Bar, it did NOT close the current circuit for open tabs.  But if I opened a new tab & a new site, it appeared to use a different circuit than the one that existing tabs were connected through.

In re reading the intro for new feature, "New Identity," I thought it said it would close all tabs, establish a new circuit, etc.  Maybe that changed later on, to just affect NEW tabs?  There wasn't an onion icon in addon bar, for 3.0a4 Windows (by default).

Last edited 3 years ago by joebt (previous) (diff)

comment:3 in reply to: ↑ 2 Changed 3 years ago by torland

Replying to joebt:

Not sure what you mean by "restarted," but in 3.0a4 on Vista x64, clicking New Identity closes open tabs & leaves the "about Tor" tab /page open.  But the browser doesn't close, then restart.

"restarted" mean that after pressing New identity TBB closes the main window and after reappearing all my open tabs are gone.

comment:4 Changed 3 years ago by arma

Seems to me that the first time the user selects new identity, they should have to confirm that they know they're about to lose all their tabs. Maybe with a little "don't ask me next time" option too.

(Was there another ticket where this approach was suggested, or am I imagining things and this one is it?)

comment:6 Changed 3 years ago by arma

And also raised at https://blog.torproject.org/blog/tor-browser-bundle-35rc1-released#comment-41060

This seems like a commonly encountered issue.

comment:7 Changed 3 years ago by arma

  • Keywords tbb-newnym added

comment:8 Changed 3 years ago by arma

  • Summary changed from TBB-3 restarts on clicking "New Identity" to TBB3 new identity surprises users by closing all tabs

I closed #9292 and #4393 as duplicates of this one.

comment:9 Changed 3 years ago by mikeperry

See also #10400.

comment:10 Changed 3 years ago by mikeperry

  • Keywords extdev-interview added

comment:11 Changed 3 years ago by mikeperry

Closing #9575 as a dup of this.

comment:12 Changed 3 years ago by gk

  • Cc gk added

comment:13 Changed 3 years ago by isis

  • Cc isis added

A TBB user on Twitter complained to me about this behaviour, and had the following UI suggestions:

https://trac.torproject.org/projects/tor/raw-attachment/ticket/9906/TICKET-9906-user-feedback-from-twitter.jpg

comment:14 Changed 3 years ago by isis

  • Keywords tbb-helpdesk-frequent added

comment:15 Changed 3 years ago by gk

Closing #11520 as a dup of this.

comment:16 Changed 3 years ago by mcs

  • Cc mcs added

comment:17 Changed 3 years ago by erinn

  • Component changed from TorBrowserButton to Tor Browser
  • Keywords tbb-torbutton added
  • Owner changed from mikeperry to tbb-team

comment:18 Changed 3 years ago by gk

  • Cc gigel added

Closed #13075 as duplicate.

comment:19 Changed 2 years ago by asn

See https://blog.torproject.org/comment/reply/941/79211 for this comment:

I'd like to have an option for not closing the browser window upon changing identity.
There is already a preference "extensions.torbutton.close_newnym" for this in about:config, but it doesn't work because a "return" statement is missing after the preference test in chrome/content/torbutton.js:


function torbutton_close_on_toggle(mode, newnym):
[…]
if (newnym) {
if (!close_newnym) {
torbutton_log(3, "Not closing tabs");
}
} else if((mode && !close_nontor) || (!mode && !close_tor)) {
torbutton_log(3, "Not closing tabs");
return;
}
[…]
}

comment:20 Changed 2 years ago by mikeperry

  • Keywords tbb-usability added

comment:21 Changed 2 years ago by mikeperry

  • Keywords TorBrowserTeam201502 MikePerry201502 added

comment:22 Changed 2 years ago by mikeperry

  • Keywords TorBrowserTeam201502R added; TorBrowserTeam201502 removed
  • Status changed from new to needs_review
  • Summary changed from TBB3 new identity surprises users by closing all tabs to TBB new identity surprises users by closing all tabs

comment:23 Changed 2 years ago by brade

  • Keywords TorBrowserTeam201502 added; TorBrowserTeam201502R removed
  • Status changed from needs_review to new

Mark and I reviewed this and it looks good (and I think it will be very helpful to new TB users).

You could replace "var" with "let" and (I think) use Ci in place of Components.interfaces in the "var prompts = ..." statement.

comment:24 Changed 2 years ago by mikeperry

  • Resolution set to fixed
  • Status changed from new to closed

Ok, I replaced the vars with lets, and used Ci, and pushed this for 4.5a4. Thanks for the review!

Note: See TracTickets for help on using tickets.