Opened 4 years ago

Closed 9 months ago

#9913 closed enhancement (fixed)

Explain relay flags in detail view using tooltips

Reported by: f3ndot Owned by: irl
Priority: Medium Milestone:
Component: Metrics/Atlas Version:
Severity: Normal Keywords: flag description tooltip flags
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Personally, having known about Tor for some time, I still didn't know what all of the flags meant.

Using https://gitweb.torproject.org/torspec.git/blob/HEAD:/dir-spec.txt#l1768 as my guide I wrote some descriptions and have them display as a tooltip when you hover over each flag in the detail view.

The work was done in https://github.com/f3ndot/torproject-atlas/compare/explain-relay-flags and attached is the patch file.

Child Tickets

Attachments (2)

explain-relay-flags.patch (4.7 KB) - added by f3ndot 4 years ago.
flags-not-good.png (20.1 KB) - added by irl 9 months ago.
Rendering of the flag tooltips in Firefox ESR 45.4.0

Download all attachments as: .zip

Change History (16)

Changed 4 years ago by f3ndot

Attachment: explain-relay-flags.patch added

comment:1 Changed 4 years ago by f3ndot

Status: newneeds_review

comment:2 Changed 4 years ago by karsten

Status: needs_reviewneeds_information

Thanks for the patch! I moved the discussion of phrasings to StackExchange, because I can't really say what relay operators find easiest to understand. Let's wait a few days for responses there and then apply the (possibly modified) patch. Thanks!

comment:3 Changed 4 years ago by f3ndot

I appreciate the SE post, those phrases were best-effort guesses :-)

comment:4 Changed 18 months ago by karsten

Severity: Normal

See also #7939 which I just closed as near duplicate of this ticket.

comment:5 Changed 12 months ago by irl

Owner: changed from f3ndot to irl
Status: needs_informationaccepted

comment:6 Changed 9 months ago by RaBe

Status: acceptedneeds_review

I updated the patch for the current atlas website version and used the texts from the link in the comment in #7939. Here's the patch:

https://github.com/RaphaelBergmann/atlas/commit/ef7b682fc12223193efff2bebe8538aad3bb149d

(I also prepared the flag "NoEdConsensus" which was in the documentation, but has not yet been implemented on Atlas.)

comment:7 Changed 9 months ago by irl

Owner: changed from irl to RaBe
Status: needs_reviewassigned

This doesn't seem to render correctly in Firefox ):

I'll attach a screenshot. I'm using Firefox ESR 45.4.0.

I get $.fn.tooltip is not defined in the console output.

Changed 9 months ago by irl

Attachment: flags-not-good.png added

Rendering of the flag tooltips in Firefox ESR 45.4.0

comment:8 Changed 9 months ago by RaBe

Owner: changed from RaBe to irl

It was the "popover" function that threw that error and stopped all following JS to work (Firefox only), so I removed it and then replaced the popovers with tooltips so we're not losing any functionality. Also, I fixed a small issue with the search table, where tooltips were not working properly when filtering results or changing the "show entries" value.

https://github.com/RaphaelBergmann/atlas/compare/task-9913

comment:9 Changed 9 months ago by RaBe

Status: assignedneeds_review

comment:10 Changed 9 months ago by irl

Owner: irl deleted
Status: needs_reviewassigned

The fixes look good, but I can't merge that. You'll need to rebase the commits against the current master branch of https://gitweb.torproject.org/atlas.git. For example, that branch has 5 commits titled "Inserted zero width space character to wrap fingerprint line on smaller displays".

Whenever starting on a new ticket, please checkout master, pull to have the latest commits from the git.tpo repo, then branch, and rebase against the latest from git.tpo before adding a patch to the ticket.

This helps with testing as the patch is as close as possible to based on the latest sources, and also helps with merging and keeping a clean history in the git repository.

comment:11 Changed 9 months ago by irl

Status: assignedneeds_revision

comment:12 Changed 9 months ago by RaBe

Owner: set to irl
Status: needs_revisionassigned

Oh, I'm sorry. So here's the new patch (for some reason I did not manage to "fix" the other branch...):

https://github.com/RaphaelBergmann/atlas/compare/task-9913-new

comment:13 Changed 9 months ago by RaBe

Status: assignedneeds_review

comment:14 Changed 9 months ago by irl

Resolution: fixed
Status: needs_reviewclosed

LGTM. Merged.

Note: See TracTickets for help on using tickets.