Opened 6 years ago

Closed 5 years ago

#9956 closed defect (user disappeared)

FF24 CPU loop after HTTPS-Everywhere 3.4.2 install

Reported by: DeltaBravo Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I updated the extensions on my Firefox 24.0 setup, one of which being HTTPS-Everywhere, and on restarting Firefox went into a CPU loop showing 100% in Task Manager on Windows 7 64-bit.

Left things for 10 mins to see if would clear itself but no good. Killing off Firefox process and restarting it would result in the same CPU bound process. Not sure which extension could be at fault so rather than safe mode disable, I did a full firefox reset to get it working again on a new profile.

I slowly reinstalled my usual extensions one by one and when it came to HTTPS-Everywhere 3.4.2 (latest as of 10/10/13) the CPU looping issue appeared once more. Disabling it in safe mode meant that Firefox would start and work as normal, but enabling it meant 100% CPU and start window never opening.

Interestingly, I removed HTTPS-Everywhere 3.4.2 and installed 3.2.2 which started up fine, no problem at all. This was alongside the other 40 or so extensions I use so all points to something odd that has been introduced since 3.2.2.

Hope this information helps locate the issue!

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by zyan

Interesting. Are you still having this issue in 3.4.3?

comment:2 Changed 5 years ago by jsha

Resolution: user disappeared
Status: newclosed

Can't reproduce. Please reopen if this still reproduces for you.

Note: See TracTickets for help on using tickets.