Opened 6 years ago

Closed 21 months ago

#9981 closed defect (not a bug)

Google APIs rule breaks a tool for a python class

Reported by: micahlee Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This website has a browser-based python interpreter for a Coursera python class:

http://www.codeskulptor.org/#examples-hello_world.py

The Google APIs rule causes an error where "Unable to load file: examples-hello_world.py" is alerted. Disabling the rule fixes it.

Child Tickets

Change History (3)

comment:1 Changed 6 years ago by micahlee

My best guess is that that URL attempts to load:

http://codeskulptor-examples.commondatastorage.googleapis.com/examples-hello_world.py

And it gets rewritten to:

https://codeskulptor-examples.commondatastorage.googleapis.com/examples-hello_world.py

Only both URLs work fine. I even tried making an ajax request from that website by running this in a javascript console:

$.ajax({
    url:'https://codeskulptor-examples.commondatastorage.googleapis.com/examples-hello_world.py',
    success:function(data){ alert('success! ' + data); },
    error:function(err){ alert('error! '+err); }
});

It alerts the right code.

comment:2 Changed 23 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:3 Changed 21 months ago by cypherpunks

Resolution: not a bug
Status: newclosed

googleapis.com is now HSTS preloaded and the reported error happens even when HTTPS Everywhere is disabled. It's now up to the codeskulptor webmasters to fix it.

Note: See TracTickets for help on using tickets.