Opened 6 years ago

Closed 5 years ago

#9983 closed defect (not a bug)

Relay working but no DirPort

Reported by: Starbase69 Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.3.25
Severity: Keywords: DirPort
Cc: christopher.forsb@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi! I recently started my Tor Relay server and it is working like a charm.

But the problem is that according to the torstatus.blutmagie.de, my server's "Directory Server Port" is "None".
( http://torstatus.blutmagie.de/router_detail.php?FP=af23b43b5ffa8c613279598f2386618c7403f565 )

The ports are open and is working according to nmap/canyouseeme.org etc

DirPort 80
DirPortFrontPage /etc/tor/tor-exit-notice.html

Child Tickets

Change History (3)

comment:1 Changed 6 years ago by Starbase69

Priority: normalmajor

comment:2 Changed 6 years ago by arma

Priority: majornormal

Thanks for running a relay!

Unfortunately, trac is not the support desk. This doesn't sound like a Tor bug. See also https://www.torproject.org/about/contact

My guess is that you have accounting limits set, or something else that makes Tor opt not to advertise your DirPort. See your log messages when your relay starts -- hopefully it explains there?

comment:3 Changed 5 years ago by arma

Resolution: not a bug
Status: newclosed

Closing on the theory that surely the user resolved his/her problem now, and in any case the helpdesk remains the right place to go for user support questions.

Note: See TracTickets for help on using tickets.