Opened 6 years ago

Closed 4 years ago

#9984 closed enhancement (fixed)

Instantbird support for Tor Launcher

Reported by: sukhbir Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Normal Keywords: MikePerry201312R SponsorO
Cc: mikeperry, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I thought we should get this started!

I have attached the trivial patch that adds support for Instantbird to Tor Launcher. I have tested it and it is working fine, except for this message in the error console:

[10-15 23:11:37] TorLauncher NOTE: _parseBootstrapStatus: missing BOOTSTRAP

Seems like we can ignore this safely?

Note that there are some other things that we will probably tweak later, such as minVersion and maxVersion but this patch takes care of the important stuff first.

Child Tickets

Attachments (2)

instantbird.patch (2.2 KB) - added by sukhbir 6 years ago.
Patch for Instantbird support
proxyext_compatibility.patch (2.9 KB) - added by Ry 6 years ago.
Support proxy extension files

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by sukhbir

Attachment: instantbird.patch added

Patch for Instantbird support

Changed 6 years ago by Ry

Support proxy extension files

comment:1 Changed 6 years ago by mcs

Cc: mcs added

comment:2 Changed 6 years ago by mikeperry

Keywords: MikePerry201311R added

comment:3 Changed 6 years ago by mikeperry

Status: newneeds_revision

Sukbir: I have merged your patch. In the future though, please produce patches using git format-patch. Those are easier to apply than whatever you did here.

Ry: Your patch has a typo in it. Was it tested? If so, on which Mozilla platforms+versions?

Sukbir: Were you working with Ry on that proxyext patch? Do we actually need it?

comment:4 Changed 6 years ago by mikeperry

Keywords: MikePerry201312R added; MikePerry201311R removed

comment:5 Changed 6 years ago by arlolra

Keywords: SponsorO added

comment:6 Changed 4 years ago by mcs

Status: needs_revisionneeds_information

Is there more to do for this ticket or should it be closed? Does Instantbird need the changes in proxyext_compatibility.patch ?

comment:7 Changed 4 years ago by mcs

Resolution: fixed
Severity: Normal
Status: needs_informationclosed

Please reopen this ticket or file a new ticket if there is more work to be done for Instantbird/Tor Messenger.

Note: See TracTickets for help on using tickets.