wiki:doc/TorBOX/Dev/ArchivedDiscussion/MISC

Version 1 (modified by cypherpunks, 7 years ago) (diff)

--

Stuff that doesn't fit…

this is only temporary anyway, till we get a real bug tracker.

Problem getting software form Tails [SOLVED]

  • (proper) Following Tails is also very hard. I though about grabbing tails_htp. They have a git but that's not protected by SSL or SSH. Only way to safely extract something out Tails is downloading the iso, verifying the iso, unpacking squashfs (btw: "sudo unsquashfs -x -dest /home/user/tails filesystem.squashfs" and grabbing it from there. They also don't have an apt repository yet and they are also not like upstreaming all their work.
  • (anonymous) but they say git is signed, what's the problem? https://mailman.boum.org/pipermail/tails-dev/2012-June/001254.html
    • (proper) Do you know how to verify it? I haven't found out.
      • (anonymous) git tag -v; commits after the last signed tag are not to be trusted. There are tons of git tutorials and guides.
      • (proper) I was on the wrong path, understood "only the download iso is signed". "git tag -v 0.12" worked for me.
  • (proper) I'd also like to extract torsocks/libtorsocks from Tails, because they fixed the "The symbol res_query() was not found in any shared library. The error reported was: not found!" bug. Perhaps that's not necessary and we can use the Debian package, if they fixed that upstream.