Ticket #25664: 0001-Bug-25664-Update-libc-version-requirement-for-Rust.patch

File 0001-Bug-25664-Update-libc-version-requirement-for-Rust.patch, 1.3 KB (added by gk, 2 years ago)
  • configure.ac

    From 6deb12f9199419987611a84994c72b3873889c0b Mon Sep 17 00:00:00 2001
    From: Georg Koppen <gk@torproject.org>
    Date: Wed, 28 Mar 2018 10:19:31 +0000
    Subject: [PATCH] Bug 25664: Update libc version requirement for Rust
    
    When merging the patches for #25310 the libc version requirement in
    `GettingStartedRust.md` and `configure.ac` did not get updated to the
    now needed 0.2.39.
    
    diff --git a/configure.ac b/configure.ac
    index d7cc05c09..83760165e 100644
    a b fi 
    281281AM_CONDITIONAL(USEPYTHON, [test "x$PYTHON" != "x"])
    282282
    283283dnl List all external rust crates we depend on here. Include the version
    284 rust_crates="libc-0.2.22"
     284rust_crates="libc-0.2.39"
    285285AC_SUBST(rust_crates)
    286286
    287287ifdef([AC_C_FLEXIBLE_ARRAY_MEMBER], [
  • doc/HACKING/GettingStartedRust.md

    diff --git a/doc/HACKING/GettingStartedRust.md b/doc/HACKING/GettingStartedRust.md
    index f5914bc87..a533ba8a2 100644
    a b fetching dependencies from Cargo or specifying a local directory. 
    6565
    6666You'll need the following Rust dependencies (as of this writing):
    6767
    68     libc==0.2.22
     68    libc==0.2.39
    6969
    7070We vendor our Rust dependencies in a separate repo using
    7171[cargo-vendor](https://github.com/alexcrichton/cargo-vendor).  To use