Opened 5 years ago

Closed 5 years ago

#11700 closed defect (fixed)

HTTPS Everywhere linked to Firefox crashes

Reported by: Veeshush Owned by: zyan
Priority: High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: crash https everywhere firefox
Cc: trishank@…, James, Paige Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

See Bug 999434
https://bugzilla.mozilla.org/show_bug.cgi?id=999434

I've been getting a lot of EXCEPTION_ACCESS_VIOLATION_READ crashes myself within the last month, both with https-everywhere-4.0development.16.xpi and https-everywhere-3.5.1.xpi. I at least wanted to report it here and see if it's a known issue and is being worked on or what. If you'd want crash dumps or whatnot, I'd be happy to submit whatever. Thanks.

Child Tickets

Change History (25)

comment:1 Changed 5 years ago by zyan

I haven't seen this on my system (Debian Jessie, Firefox 29). What os/firefox version are you using? Did you also get crashes with 4.0dev.15?

comment:2 in reply to:  1 Changed 5 years ago by Veeshush

Replying to zyan:

I haven't seen this on my system (Debian Jessie, Firefox 29). What os/firefox version are you using? Did you also get crashes with 4.0dev.15?

I've experienced the crashes on 3 separate systems, all using Windows 7 64bit with Firefox 28 and 29. I'll note though I also don't get any crashes with Tails 1.0 (on the same systems), which is Debian based.

I haven't used/tried 4.0dev.15.

Here's one of my last crash reports: https://crash-stats.mozilla.com/report/index/649fa19e-8cc1-41f3-b277-6bca72140503 For some reason it has been a few days since it has last crashed. I'll see if I can get more of a step by step to reliably reproduce it.

But again, anything I can do to help, let me know. Sorry I didn't mention these details before in the first post though.

EDIT

Well, minutes after I posted everything above, it crashed: https://crash-stats.mozilla.com/report/index/96462e5e-d014-4c9a-abe1-79bb92140506

EDIT2

Another crash: https://crash-stats.mozilla.com/report/index/03c3be25-6827-469d-be6d-14c222140507

I'm not certain if all these are related to HTTPS Everywhere, though I'm sure that first is from the comments ( https://bugzilla.mozilla.org/show_bug.cgi?id=999434 )

Last edited 5 years ago by Veeshush (previous) (diff)

comment:3 Changed 5 years ago by cypherpunks

I'm having about 2-5 crashes per day here. They stopped when I disabled HTTPS Everywhere. I'm using the latest dev version.

Here is one: https://crash-stats.mozilla.com/report/index/bd1311b5-4f57-4276-9cdc-642b12140511

comment:4 Changed 5 years ago by marcopal

The crash signature isn't always the same. The only thing in common is that is always EXCEPTION_ACCESS_VIOLATION_READ or EXCEPTION_ACCESS_VIOLATION_WRITE. It always happens when some page is loading or switching between tabs, never when idle. I don't know exactly how to reproduce it...
Here I post a set of crashes that I've been having, the first is from 2014-04-16, two days after https everywhere 3.5 was released(now at 3.5.1). Also I tried a few days ago to disable that extension and it didn't happened anymore.
The first set is from Windows 7 64bit and the last two are from Windows 7 32bit.

https://crash-stats.mozilla.com/report/index/bp-9ac51c25-83ed-4204-99a3-ffb5f2140511
https://crash-stats.mozilla.com/report/index/bp-a05461ba-9fe3-4746-a906-2af402140510
https://crash-stats.mozilla.com/report/index/bp-2b0fbb55-a105-4c7d-a173-22cfd2140502
https://crash-stats.mozilla.com/report/index/bp-a30ffc2e-7a15-4b38-90bc-a364b2140501
https://crash-stats.mozilla.com/report/index/bp-b9120670-8bee-46ee-8748-b258a2140427
https://crash-stats.mozilla.com/report/index/bp-51a03f55-a9b9-4ffb-a25b-2a9142140426
https://crash-stats.mozilla.com/report/index/bp-fa220650-f090-4f50-9e81-6218e2140424
https://crash-stats.mozilla.com/report/index/bp-60cc747d-335d-428a-9299-ec4a12140424
https://crash-stats.mozilla.com/report/index/bp-157d40fc-784f-4a9b-bad8-e09332140423
https://crash-stats.mozilla.com/report/index/bp-bb33e538-92ed-499a-95ff-5837a2140421
https://crash-stats.mozilla.com/report/index/bp-549953e6-f598-453f-b2c7-360ed2140419
https://crash-stats.mozilla.com/report/index/bp-c725fa9e-4ac0-43a1-9d1c-c318c2140418
https://crash-stats.mozilla.com/report/index/bp-ac73d0b1-874b-4ad8-aa1c-4dafc2140417
https://crash-stats.mozilla.com/report/index/bp-58720b81-ca3f-4c7f-bf7c-97d602140417
https://crash-stats.mozilla.com/report/index/bp-d123757b-7382-4bd2-b83e-eb02b2140416
https://crash-stats.mozilla.com/report/index/bp-f0c0da89-895b-4c4c-9090-8aa982140416

https://crash-stats.mozilla.com/report/index/6d05241f-7247-45dd-baba-4328b2140429
https://crash-stats.mozilla.com/report/index/51b15525-e857-4ca4-b1ac-97f002140502

Posted also on https://bugzilla.mozilla.org/show_bug.cgi?id=999434

comment:5 Changed 5 years ago by RdVortex

Experiencing the same problem on all my three computers (Win 7 32-bit, Win 7 64-bit, Win 8.1 64-bit). Also like marcopal I can' really reproduce the bug easily as it happens so randomly. In either case disabling HTTPS Everywhere solves the problem. Bug exist on both 3.5.1 and 4.0development.16

Two crash reports from my laptop running the 32-bit Win 7, one with 3.5.1 and one with 4.0dev.16:

https://crash-stats.mozilla.com/report/index/6d582aaf-e002-4c2b-9974-4d9c52140521

https://crash-stats.mozilla.com/report/index/ab74533d-23d8-432d-a5fc-be2412140521

It's impossible to use HTTPS Everywhere with this bug since it can cause Firefox to crash several times per day.

Downgrading to 3.4.5 and disabling auto updates solves the problem.

Last edited 5 years ago by RdVortex (previous) (diff)

comment:6 Changed 5 years ago by dachshund

Cc: trishank@… added

I may have fairly good empirical evidence that https-everywhere 3.5.1 or 4.0development is correlated with Firefox crashes of certain signatures. What follows are the crash signatures in which https-everywhere is present in all crash reports of those signatures.

Extensions in all reports with the same signature (https://crash-stats.mozilla.com/report/list/partials/reports/?product=Firefox&signature=nsEventQueue%3A%3APutEvent): {u'https-everywhere@…': set([u'4.0development.16', u'3.5.1'])}

Extensions in all reports with the same signature (https://crash-stats.mozilla.com/report/list/partials/reports/?product=Firefox&signature=js%3A%3AGCMarker%3A%3AGrayCallback): {u'https-everywhere@…': set([u'4.0development.17', u'3.5.1'])}

Extensions in all reports with the same signature (https://crash-stats.mozilla.com/report/list/partials/reports/?product=Firefox&signature=mozilla%3A%3Anet%3A%3AHttpBaseChannel%3A%3AGetURI%28nsIURI%2A%2A%29): {u'https-everywhere@…': set([u'4.0development.16', u'3.5.1'])}

Please let me know if something does not make sense.

comment:7 Changed 5 years ago by James Paige

Cc: James Paige added

comment:8 Changed 5 years ago by James Paige

I have seen this 1 to 2 times every day since Firefox 29 was released. Disabling HTTPS Everywhere prevents the crash

Tested on both Firefox 29.0.1 for Mac OS X 10.7.5
And Firefox 29.0 for Ubuntu Linux 12.04 (x86)

EDIT: I should have mentioned, that the crash always happenes within 1-2 seconds of opening a new tab (but definitely not every time I opened a new tab, just once or twice a day immediately after opening a new tab)

Last edited 5 years ago by James Paige (previous) (diff)

comment:9 Changed 5 years ago by bmenrigh

I've been seeing crashing on FF 28, 29, and now 30 that I just tracked down to HTTPS Everywhere 3.5.1. It seems like the crashing is due to some sort of random memory corruption because the backtrace in GDB is random and different every time.

I'm running 64bit Firefox on Linux, compiled from source (via Gentoo).

The crashing was easily reproducible by browsing a local Bugzilla instance. Usually Firefox would crash on the very first bug I opened but when it survived the first, it never made it past the third before crashing.

When I avoided the local bugzilla instance the crashing was much more random an unpredictable but I'd usually get > 1 random crash a day.

comment:10 Changed 5 years ago by zyan

Still tracking this down. FWIW, there is more discussion over at https://github.com/EFForg/https-everywhere/issues/262 (our other bug tracker).

comment:11 Changed 5 years ago by zyan

Has anyone confirmed/denied that 4.0dev.17 fixes the crash? (I would assume not.)

comment:12 Changed 5 years ago by zyan

Also, if it turns out this is happening on 4.0dev.15 but not 4.0dev.14, it's likely related to the fact that we transitioned from using an in-memory xml data structure for rulesets to a sqlite db.

Last edited 5 years ago by zyan (previous) (diff)

comment:13 in reply to:  11 Changed 5 years ago by dachshund

Replying to zyan:

Has anyone confirmed/denied that 4.0dev.17 fixes the crash? (I would assume not.)

Yan Zhu, thanks for looking into this. If you look at my previous comment, it seems that 3.5.1, 4.0development.16 and 4.0development17 are all involved. I have found Firefox crash signatures in which HTTPS Everywhere (in either one of these versions) are involved in all reports.

comment:14 Changed 5 years ago by zyan

Someone thinks that this bug goes away when they disable SSL Observatory; can others confirm/deny?

Also: go to "about:config", turn extensions.https_everywhere.logLevel to 5 for verbose logging. Would help to get logs from a crash.

Last edited 5 years ago by zyan (previous) (diff)

comment:15 Changed 5 years ago by sirald66

https://crash-stats.mozilla.com/report/index/1f5974a6-5d8d-454a-866f-5f36e2140618

[HP G72-253NR - WIN 7 HP SP1 x64 - FIREFOX 29.0.1 - HTTPS-E 4.0.DEV17]

RESULT: Upon upgrading HTTPS-E from 3.5.1 to DEV17, browser crashed on restart.

comment:16 Changed 5 years ago by Rufous

I tried turning off SSL Observatory and this is all that I got instead of the settings:

An orange window saying this:

XML-tolkningsfel: fel i behandling av extern entitetsreferens
Adress: !chrome://https-everywhere/content/observatory-preferences.xul
Radnummer 4, Kolumn 80:<!DOCTYPE overlay SYSTEM "!chrome://https-everywhere/locale/ssl-observatory.dtd">
-------------------------------------------------------------------------------!^

Image: https://i.imgur.com/77Hv9EM.jpg

I'm using Dev17.

I had this issue before but forgot about it, I tried to uninstall but I remember it didn't help. Anyone got any ideas?

Not sure if this is related, If i should post this somewhere else let me know.

Last edited 5 years ago by Rufous (previous) (diff)

comment:17 Changed 5 years ago by zyan

Rufous: That is a separate bug! But one that we should also fix in the release this week or next weeek.

PS - several more people confirmed that turning off SSL Obs. fixed the browser crashes.

comment:18 in reply to:  17 Changed 5 years ago by Rufous

Replying to zyan:

Hmm, OK. Is there no other way for me to turn off SSL Obs before this patch goes out? I tried reinstalling the addon but my settings persist.

comment:19 Changed 5 years ago by zyan

rufous: click on https everywhere icon > "SSL Observatory Preferences"

comment:20 in reply to:  19 ; Changed 5 years ago by Rufous

Replying to zyan:

rufous: click on https everywhere icon > "SSL Observatory Preferences"

See reply 16 for what happens when i do that.

comment:21 in reply to:  20 Changed 5 years ago by zyan

Replying to Rufous:

Replying to zyan:

rufous: click on https everywhere icon > "SSL Observatory Preferences"

See reply 16 for what happens when i do that.

Oops. In that case, go to "about:config", set "https_everywhere._observatory.enabled" to false.

comment:22 Changed 5 years ago by zyan

Please test out this version for crashes: https://www.eff.org/files/https-everywhere-3.5.1~pre.xpi

(It's 3.5.1 with SSL Obs. reverted to 3.4.5)

comment:23 Changed 5 years ago by Veeshush

3.5.3 ​https://www.eff.org/files/https-everywhere-3.5.3.xpi

Revert components/ssl-observatory.js to 3.4.5, possibly fixing crash bug (Github #262)

https://www.eff.org/files/Changelog.txt

Try it out guys.

comment:24 in reply to:  23 Changed 5 years ago by sirald66

Worked for me.

Replying to Veeshush:

3.5.3 ​https://www.eff.org/files/https-everywhere-3.5.3.xpi

Revert components/ssl-observatory.js to 3.4.5, possibly fixing crash bug (Github #262)

https://www.eff.org/files/Changelog.txt

Try it out guys.

comment:25 Changed 5 years ago by jsha

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.