Opened 6 months ago

Last modified 5 months ago

#28690 needs_information defect

Problems running, installing and updating Torbrowser

Reported by: justmeee Owned by: tbb-team
Priority: Immediate Milestone:
Component: Applications/Tor Browser Version:
Severity: Critical Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Windows 7, 64-bit, Torbrowser

I'm having problems getting it to run and install.

See previous ticket here for history, we thought it was fixed but not quite: https://trac.torproject.org/projects/tor/ticket/28211#ticket

Granted the newer version does not have that first hang up issue, so that part is better; however the problem now is getting it to install, run and update.

You may also want to look into why Torbrowser keeps triggering virus alerts so others don't have that issue. I use Trend Micro if it matters.

So what happened is the computer restarted and removed those two items mentioned in the previous ticket, then TorBrowser stopped working completely.

So i restored them, which also adds them to the exception list so they don't get flagged again, but still the browser would not work again.

Then I reinstalled it (Note: as far as installation goes, the only version that does NOT give me any errors during install is that link you gave me, the 8.0a8 - as of today, all of the others, including the Dec 2 nightlies, still will Not install).

So I reinstalled the 8.0a8 but now it will not update. I got the following message:
"There were problems checking for, downloading or installing this update. Tor Browser could not be updated because:
The updated could not be installed (patch apply failed)."

Then it tells me it will try to upload a full version, but then the update keeps getting stuck, first around only 290KB, so I close the update then start again, then it gets stuck again around 5MB, so I close the update window a second time and go back to help/about to get it going again. I may have to do it a third/fourth time.

The last time (the previous ticket) I did get these errors, but last time I just kept closing the trying again and again until it eventually installed, which took about 7 attempts in total. However this time, it's not working at all.

I tried turning off the virus protections and doing a fresh install.

Even after turning off virus protection and trying a fresh install, I get the same errors and stalls during update attempts. Plus even with the virus protection off, the other versions will not install just like before, only 8.0a8 will install.

So at this time, I'm using 8.0a8 since it's the only version 8 I can use, unless I go back to 7.*.

Some help please?

Child Tickets

Attachments (5)

1 torbrowser hang dec 5 2018.png (48.0 KB) - added by justmeee 6 months ago.
2 torbrowser hang dec 5 2018.png (53.5 KB) - added by justmeee 6 months ago.
3 Torbrowser hang just from trying to click on another tab.png (287.5 KB) - added by justmeee 6 months ago.
3 Torbrowser hang just from trying to click on another tab
4 sameTorbrowser hang as 3 just from trying to click on another tab again but 3 mins later.png (218.7 KB) - added by justmeee 6 months ago.
4 sameTorbrowser hang as 3 just from trying to click on another tab again but 3 mins later
5 sameTorbrowser hang from 3 and 4 just waited several mor minutes and no change.png (218.7 KB) - added by justmeee 6 months ago.
5 sameTorbrowser hang from 3 and 4 just waited several mor minutes and no change

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 months ago by teor

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

Changed 6 months ago by justmeee

Changed 6 months ago by justmeee

Changed 6 months ago by justmeee

3 Torbrowser hang just from trying to click on another tab

Changed 6 months ago by justmeee

4 sameTorbrowser hang as 3 just from trying to click on another tab again but 3 mins later

Changed 6 months ago by justmeee

5 sameTorbrowser hang from 3 and 4 just waited several mor minutes and no change

comment:2 Changed 6 months ago by justmeee

More info:

After many tires, I got it to update in a different location, though it took numerous attempts. However even though it updated, unlike before, the hang problem is back now too from the original ticket. I can't work on it, so I'm not posting from someone else's machine.

So the noted problems:
1) Can't install because it tells me I need to have Windows 7 installed even though I do have windows 7 64 bit installed
2) Could only get that one version to install, 8.0a8 , and it should be noted that it never gives you any notice that the install is complete, it just disappears, so you don't know if it's done or if it stopped, or what. It needs a completion dialog.

Additionally, updates are a problem.

a) The browser updates trigger the Trend Micro virus but even after telling antivirus to allow the components that triggered it, which also adds it to the exception list, the program still won't even run anymore - even after turning off antivirus, it still will not work and a fresh copy won't install/work right after that in the same location.
b) a fresh install in a different location with antivirus turned off allowed for a fresh install. It still had trouble updated per the above notes, so it took a long time and many tries.

However, after the updates completed, we're back to square one where it's hanging so badly I can't use it.

Screen shots of some of the hangs attached, the names of the files note the condition and when. The first one happened when I was just trying to type an address in the bar as you can see. The second was after the first stopped hanging, I just closed that tab and then tried to click on the NoScript icon for another webpage, as you can see, that's it, and it hung up again. Three and four are labeled. Note the last one, it had been hanging for several minutes with no change. Then later then when it finally stopped hanging, it only functioned for about 15 seconds then hung up like that again. So it's back to not usable for me.

The interface looks good, but it looks like I'm going to have to go back to 7.?, because it was the last one that worked. But I would like to update sometime soon.

So, PLEASE HELP.

Thank you very much.

comment:3 in reply to:  2 Changed 5 months ago by gk

Status: newneeds_information

Replying to justmeee:

More info:

After many tires, I got it to update in a different location, though it took numerous attempts. However even though it updated, unlike before, the hang problem is back now too from the original ticket. I can't work on it, so I'm not posting from someone else's machine.

So the noted problems:
1) Can't install because it tells me I need to have Windows 7 installed even though I do have windows 7 64 bit installed

Okay, I opened #28819 for that particular problem to not clutter this bug report any more.

2) Could only get that one version to install, 8.0a8 , and it should be noted that it never gives you any notice that the install is complete, it just disappears, so you don't know if it's done or if it stopped, or what. It needs a completion dialog.

Okay, let's revisit that once we solved #28819 and are using the latest version we provide.

Additionally, updates are a problem.

a) The browser updates trigger the Trend Micro virus but even after telling antivirus to allow the components that triggered it, which also adds it to the exception list, the program still won't even run anymore - even after turning off antivirus, it still will not work and a fresh copy won't install/work right after that in the same location.
b) a fresh install in a different location with antivirus turned off allowed for a fresh install. It still had trouble updated per the above notes, so it took a long time and many tries.

I am afraid there is not much we can do to fix this situation. You could try to contact the Trend Micro folks to fix their software or get rid off it. Moreover, just turning it off might not be enough to actually stop it. You might want to be sure about the Trend Mirco software not interfering by removing it (and be it just temporarily).

However, after the updates completed, we're back to square one where it's hanging so badly I can't use it.

Screen shots of some of the hangs attached, the names of the files note the condition and when. The first one happened when I was just trying to type an address in the bar as you can see. The second was after the first stopped hanging, I just closed that tab and then tried to click on the NoScript icon for another webpage, as you can see, that's it, and it hung up again. Three and four are labeled. Note the last one, it had been hanging for several minutes with no change. Then later then when it finally stopped hanging, it only functioned for about 15 seconds then hung up like that again. So it's back to not usable for me.

You have a bunch of extra extensions installed. Please use only Tor Browser as we ship it, at least for debugging purposes. Does the problem continue if you make sure you run Tor Browser without any modifications? On which security slider level are you? And how are you disabling JavaScript?

Note: See TracTickets for help on using tickets.