Opened 2 months ago

Closed 3 weeks ago

#29157 closed defect (fixed)

Modify the the threads callback error to store the error

Reported by: juga Owned by:
Priority: Medium Milestone: sbws: 1.0.x-final
Component: Core Tor/sbws Version: sbws: 1.0.2
Severity: Normal Keywords:
Cc: juga, teor Actual Points:
Parent ID: #28663 Points:
Reviewer: Sponsor:

Description

when the error comes from the measurement but not from some bug in the code.
This was proposed by teor in #28868:

Modify result_putter_error() to store an error result to the queue.

Child Tickets

Change History (3)

comment:1 Changed 6 weeks ago by juga

This has been implemented as part of https://trac.torproject.org/projects/tor/ticket/28567#comment:5.
Not creating a new branch for this ticket and cherry-picking the implementation because there'll be already many merge conflicts since the same parts of the code are being modified in different tickets.
When it's confirmed sbws doesn't stall without implementing this, this ticket can be closed.

comment:2 Changed 5 weeks ago by juga

Parent ID: #28868#28663

Change parent to #28663 so that #28868 can be closed.

comment:3 Changed 3 weeks ago by juga

Resolution: fixed
Status: newclosed

The error callback logs only exceptions when the callback could not be call, what means developer bugs
So i think it's better to print the stack, which is not in the main process but traceback.print_stack takes from the thread.
And this is already done in 8cbb73052240f685b409a89df910b915228c651c.

Note: See TracTickets for help on using tickets.